2

As I understand Cisco IOS takes subnet mask from interface to which is network connected and put it in RIPv2 updates.

Could you advice please if it possible to somehow manualy set subnet mask of RIPv2 updates (in Cisco IOS)?

For instance assuming that I have following topology:

topology

How should be configured R1 in way to advertise only network A.B.C.D/28 but not entire network A.B.C.D/24?

It's strange that configuring of subnet mask for RIPv2 is not supported by wide range of vendors (actually I don't know the one who supports it:))

Do you know if there are any RIPv2 standart limitation for it?

Thank you.

1 Answer 1

4

RIPv2 with the no auto-summary option will advertise the specific routes, not the aggregated prefix, unless you you use the ip summary-address rip interface command.

The network statements in RIP are not specifically telling RIP what prefix(es) to advertise, they tell RIP which interfaces should participate in RIP, and RIP will get the specific prefix(es) from the interface(s) which fall into the network statement. This is true for most routing protocols on Cisco routers, and it is a source of confusion for many people. For instance:

interface FastEthernet0/0
 ip address 10.1.1.1 255.255.255.0

interface FastEthernet0/1
 ip address 10.2.2.1 255.255.255.0

interface FastEthernet1/0
 ip address 172.16.1.1 255.255.255.0

router rip
 version 2
 no auto-summary
 network 10.0.0.0

The above configuration will run RIP on F0/0 and F0/1, but not F1/0. RIP will advertise two routes: 10.1.1.0/24 and 10.2.2.0/24.

There are Cisco documents, such as Configuring Routing Information Protocol which explain RIP route summarization:

Restrictions to RIP Route Summarization

Supernet advertisement (advertising any network prefix less than its classful major network) is not allowed in RIP route summarization, other than advertising a supernet learned in the routing tables. Supernets learned on any interface that is subject to configuration are still learned. For example, the following summarization is invalid:

interface E1
.
.
.
ip summary-address rip 10.0.0.0 252.0.0.0 (invalid supernet summarization)

Each route summarization on an interface must have a unique major net, even if the subnet mask is unique. For example, the following is not permitted:

interface Ethernet1
.
.
.
ip summary-address rip 10.1.0.0 255.255.0.0
ip summary-address rip 10.2.0.0 255.255.0.0 (or different mask)
7
  • Thank you for answer. For example having; interface E1 ip address 10.10.10.0 255.255.255.0 There is no way to advertise only 10.10.10.0/28 insted of configured on interface /24? Dec 13, 2015 at 7:42
  • If the subnet on the interface is a /28, then you can advertise the /28 subnet using the no auto-summary command, but you can't advertise anything with a larger mask than you have. In other words, you can't change the masks of what you advertise, except in summaries. Why, if your subnet is /24, would you want to advertise /28? That sort of thing only leads to hosts which can't be reached. Off the top of my head, I don't recall any routing protocol which allows that.
    – Ron Maupin
    Dec 13, 2015 at 8:08
  • Thanks for clarification. As far as I know OSPF is allowing it. We can specify wilcard mask of the network: router ospf 1 network 172.16.1.0 0.0.0.248 area 0 Dec 13, 2015 at 9:26
  • The network statement only specifies the interfaces which will participate in OSPF. It does not tell OSPF what prefix length to advertise. That is a real point of confusion, especially among newbies.
    – Ron Maupin
    Dec 13, 2015 at 9:29
  • @DmitriiGangan, let me put it this way: Having two interfaces, 10.0.0.1 255.255.255.252 and 10.0.0.9 255.255.255.248, and the OSPF network statement of 10.0.0.0 0.0.0.3 (your wildcard mask is wrong) will only tell OSPF to run on the first interface, and it will advertise the 10.0.0.0/30 prefix, not the 10.0.0.0/29 which the network statement translates to (wildcard 0.0.0.3=mask 255.255.255.248). The other interface will not participate in OSPF unless there is a network statement encompassing it.
    – Ron Maupin
    Dec 13, 2015 at 9:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.