2

I have a problem with vyatta 6.2 - static routing enter image description here

I want to have internet in network 192.168.0., I can ping e.g 192.168.0.59 but I have no internet connection in network 192.168.0.. I tried to add static route but but nothing happened, set protocols static route 192.168.1.0/24 next-hop 192.168.0.100

my configuration

 ethernet eth0 {
     address 192.168.1.220/24
     description LAN_01
     hw-id 00:23:54:da:d8:2e
 }
 ethernet eth1 {
     address 192.168.0.100/24
     description LAN_02
     hw-id 10:fe:ed:04:12:db
 }

gateway-address 192.168.1.1

root@ROUTER2# ping google.pl
PING google.pl (46.134.212.153) 56(84) bytes of data.
64 bytes from public103577.xdsl.centertel.pl (46.134.212.153): icmp_req=1 ttl=128 time=18.5 ms
64 bytes from public103577.xdsl.centertel.pl (46.134.212.153): icmp_req=2 ttl=128 time=18.9 ms

root@ROUTER2# ping 192.168.0.59
PING 192.168.0.59 (192.168.0.59) 56(84) bytes of data.
64 bytes from 192.168.0.59: icmp_req=1 ttl=128 time=10.7 ms
64 bytes from 192.168.0.59: icmp_req=2 ttl=128 time=0.300 ms

root@ROUTER2# show service nat rule 10 
 outbound-interface eth0
 source {
     address 192.168.0.0/24
 }
 type masquerade

thank you in advance for your help

0
1

You don't need a static route in this situation. Your router has an interface in the two /24 networks so they are automatically added to its routing table as directly connected interfaces.

Your configuration looks like it should work, so I would check anything not in your post such as:

  • 192.168.0.0/24 client IP settings
    • Default gateway should be 192.168.0.100
    • I would look here first. Your first ping to .59 took 10ms (vs 0.3ms) which may mean an arp request was made. This is unusual, since the host should have previously contacted your router in an attempt to reach the internet and should already be in the routers arp cache. Unless it isn't configured to use the router as its GW.
    • Can they ping hosts in the 192.168.1.0 network?
  • Firewall settings on the router
  • DNS
  • Conflicting NAT settings. You only need one NAT rule for basic translation.
1
  • it works thanks for your help, I forgot about default gateway on host 192.168.0.59, thanks again for your help :) Dec 22 '15 at 7:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.