1

I'm new to the networking world, and I'm trying to make a simple example yet I can't seem to get it to work. What I'm trying is just to make 2 routers situated in different areas to communicate (ping) using another router in the middle (as an ABR).

enter image description here

Here is my configuration:

router 0

interface Serial2/0
 ip address 20.1.1.2 255.255.255.252

router ospf 1
 network 20.1.1.0 0.0.0.3 area 1

router 1

interface Serial2/0
 ip address 20.1.1.1 255.255.255.252


interface Serial3/0
 ip address 20.1.2.1 255.255.255.252


router ospf 1
 network 20.1.1.0 0.0.0.3 area 1
 network 20.1.2.0 0.0.0.3 area 2

router 2

interface Serial3/0
 ip address 20.1.2.2 255.255.255.252

router ospf 1
 network 20.1.2.0 0.0.0.3 area 2

What am I doing wrong here?

4

You don't have an Area 0. Areas can only talk to Area 0. This is an OSPF basic feature which helps prevent routing loops.

Router 1 needs to be in Area 0.

Try something like this:

Router0:

interface Serial2/0
 ip address 20.1.1.2 255.255.255.252
!
router ospf 1
 network 20.1.1.0 0.0.0.3 area 1
!

Router1:

interface Loopback0
 ip address 20.0.0.1 255.255.255.255
!
interface Serial2/0
 ip address 20.1.1.1 255.255.255.252
!
interface Serial3/0
 ip address 20.1.2.1 255.255.255.252
!
router ospf 1
 network 20.0.0.1 0.0.0.0 area 0
 network 20.1.1.0 0.0.0.3 area 1
 network 20.1.2.0 0.0.0.3 area 2

Router2:

interface Serial3/0
 ip address 20.1.2.2 255.255.255.252
!
router ospf 1
 network 20.1.2.0 0.0.0.3 area 2

Just understand that Area 1 is not exchanging routes with Area 2. Each of those non-0 areas is exchanging routes with Area 0.

4
  • What do you mean? can you explain more please? should i change the config in router 1 to this: network 20.1.1.0 0.0.0.3 area 0 network 20.1.2.0 0.0.0.3 area 0 Dec 24 '15 at 23:00
  • What I mean is that one OSPF area which is not Area 0 cannot exchange routes with a different OSPF area, other Than OSPF Area 0. For your Area 1 to communicate with your Area 2, you need them to communicate through an Area 0.
    – Ron Maupin
    Dec 24 '15 at 23:04
  • i didnt get how could that be done? Dec 24 '15 at 23:05
  • OSPF areas are on interfaces. An interface on one router needs to connect to an interface in the same OSPF area on a different router. Routers which have interface(s) in Area 0 and one or more other areas are ABRs. There are multiple ways you can do this with your three routers, as long as you follow the rule that two different areas will not exchange routes unless one of them is Area 0.
    – Ron Maupin
    Dec 24 '15 at 23:16
1

You need Area 0, it's a special area that is responsible for exchanging inter-area information. In your case, you can simply fix that by turning one area to Area 0.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.