1

Im trying to connect 2 AS (each using a separate OSPF) with BGP

enter image description here

What i tried so far is: Router TTCore4:

router bgp 100
neighbor 10.0.0.34 remote-as 200
network 172.16.1.0 mask 255.255.255.0 

router ospf 1
redistribute bgp 100 metric 1 

router TelefonicaCore1:

router bgp 100
neighbor 10.0.0.33 remote-as 100
network 172.16.5.128 mask 255.255.255.192 

router ospf 1
redistribute bgp 100 metric 1 

and for the end routers (bizerte and berlin) i set a last resort to:

for bizerte: ip route 0.0.0.0 0.0.0.0 10.0.0.106 <= TTCore4 interface s1/1

for berlin: ip route 0.0.0.0 0.0.0.0 10.0.0.084 <= TelefonicaCore1 s1/0

Whenever i try to ping from Bizerte to Berlin, i get the "UUUUU" from the ping (unreachable) So how can this be done? do i have to redistribute opsf inside bgp? that would give me huge routing table?

PS: the ospf is working and the bizerte router can ping the TTCore4 router, and same thing for the berlin router.

2

If you aren't going to use BGP to advertise all your routes for an AS, then why use BGP at all? BGP tables usually are quite large.

You have a problem with your default routes because you are setting the next hop to an address which is clearly not the next hop. If you want, for example, the default route (for unknown IPv4 addresses) to go out to AS200, you should put the default route on TTCore4, pointing to AS200, and use the default-information originate command on TTCore4 in OSPF. The same thing could be done in AS200. This would eliminate using BGP between those ASes in favor of static default routes.

Unless you redistribute OSPF into BGP, or you use static routes (specific, aggregate, or default), TTCore4 has no more idea how to reach Berlin than Bizerte does.

| improve this answer | |
  • by put the default route on TTCore4, pointing to AS200 you mean like in TTCore4 ip route 0.0.0.0 0.0.0.0 10.0.0.33 ? – Ouerghi Yassine Dec 26 '15 at 3:13
  • Since it is on TTCore4, and you have the BGP neighbor in TTCore4 pointing to 10.0.0.34, I would assume it would be ip route 0.0.0.0 0.0.0.0 10.0.0.34, and just the opposite on TelefonicaCore1: ip route 0.0.0.0 0.0.0.0 10.0.0.33. Put the default-information originate OSPF command on those two routers to insert the default route into OSPF. – Ron Maupin Dec 26 '15 at 3:18
  • ok and what about the other routers, berlin and bizerte? should i put the static route too? – Ouerghi Yassine Dec 26 '15 at 3:21
  • No. You are letting OSPF advertise the default route. That is the reason for the OSPF command. You need only enter it on the border router, and it will tell all the other OSPF routers where to go with routes which they don't have. – Ron Maupin Dec 26 '15 at 3:22
  • Thank you so much, been struggling with this for 4 hours, but what if i want to add another as (lets say as 300 the top one)? should i add another static route? – Ouerghi Yassine Dec 26 '15 at 3:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.