2

My problem is that Wireshark and Scapy sniffs only ARP packets (sometimes LMNRR or DHCP - 5 packets of those in like 20 minutes..). Basically Wireshark and Scapy sniffs 1 packet in like 1-3 minutes, and most of times it is an ARP packet. enter image description here

This is the Capture Options:

enter image description here

If you need more picture write it down.

What Do I need to do to fix that?

Please Help me. thanks!

4
  • 1
    Are you able to browse and do things while you're running wireshark? Is the primary interface your using show up in wireshark? Have you tried starting wireshark as an administrator? Click the interface list in the main screen and ensure that the interface you're monitoring is sending and receiving traffic.
    – Fallacy11
    Jan 12 '16 at 1:37
  • Is the interface on which you're capturing actively being used by the machine running Wireshark? Is it an Ethernet or a Wi-Fi interface? If it's an Ethernet interface, what type of device is it plugged into? Is this on Windows?
    – user2373
    Jan 12 '16 at 1:40
  • @Fallacy11 yes I do, No it doesn't shows up in wireshark, yes I have tried to run as administrator, how do I ensure that the interfaces are sending and recieveing traffic? In wireshark it shows me that they are not recieving anything.
    – Roy Kuper
    Jan 12 '16 at 13:46
  • I'm using Wi-Fi, which explains why I don't see anything. but Wi-Fi is not in the list of the optinal interfaces in wireshark, so what do I need to do? in my laptop, I have those 3 Interfaces In the picture, and also have : Wi-Fi, Local-connection1,Local-connection2 , and in my laptop, Scapy and Wireshark works fine! So what do I need to do?
    – Roy Kuper
    Jan 12 '16 at 13:50
1

reinstall libpcap and then reboot. libpcap is what actually speaks NIC. look for errors following reinstall in logs.

1
  • does'nt work. I download, extract the all file to the wireshark file (app->wireshark) and still doesn't work
    – Roy Kuper
    Jan 15 '16 at 12:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.