2

Cisco L2 switch <--trunk--> CRS125 <--trunk--> RB750G

  • RB750G is the only device that handles routing
  • CRS125 and RB750G has interfaces with untagged traffic

I am familiar with the config on Cisco side, but had no success on Mikrotik side (keep getting locked out and have to reset the device). Mikrotik has really poor documentation and the config seems inconsistent on different models.

With RB750G, I managed to get VLAN to work by setting master port to none for each port, creating a bridge for each VLAN, then creating a bridge for each trunk with allowed vlans added to the bridge following MUM tutorial for VLAN in MikroTik. Isn't this effectively soft switching everything? Not to mention this get complicated really quick as number of vlan grows.

I had no success with the switch chip config. "Management IP Configuration" section made no sense to me and following the wiki guarantees a lockout. Do I have to create the VLANs in both switch config vlan database and router interface vlan database?

  • Unfortunately, questions about consumer-grade devices are explicitly off-topic here. You could try to ask this question on Server Fault for a business network, or on Super User for a personal network. – Ron Maupin Jul 28 '17 at 15:05
  • Oh FFS Ron, get a life. You have nothing better to do than censoring posts from ages ago. – sdaffa23fdsf Jul 29 '17 at 0:32
  • Someone else in the community pointed out that this question was off-topic. You don't understand censorship, which is a government suppression of speech. This is a community decision as to which questions are or are not on-topic here. Hyperbole is out of place. – Ron Maupin Jul 29 '17 at 4:04
1

If the CRS125 is just Layer 2 as you suggest then no router vLAN config is required.

BTW RouterOS uses the term ‘trunk’ to mean an aggregation of two or more ports to provide a single logical interface (802.3ad). A normal 802.1Q port is just a port that uses vLAN tagging.

To create a dot1Q trunk just add vLANs to the port and enable egress tagging on those vLANs. For example, here vLANs 10 & 20 are added to port ether15:

/interface ethernet switch vlan
add ports=ether15 vlan-id=10
add ports=ether15 vlan-id=20
/interface ethernet switch egress-vlan-tag
add tagged-ports=ether15 vlan-id=10
add tagged-ports=ether15 vlan-id=20

Mikrotik call a port with a native untagged vLAN a hybrid dot1Q trunk. This requires ingress and egress translations on the native vLAN. For example, to add native vLAN 1 to the above configuration:

/interface ethernet switch vlan
add ports=ether15 vlan-id=1
add ports=ether15 vlan-id=10
add ports=ether15 vlan-id=20
/interface ethernet switch egress-vlan-tag
add tagged-ports=ether15 vlan-id=10
add tagged-ports=ether15 vlan-id=20
/interface ethernet switch ingress-vlan-translation
add new-customer-vid=1 ports=ether15 sa-learning=yes
/interface ethernet switch egress-vlan-translation
add customer-vid=1 customer-vlan-format=untagged-or-tagged ports=ether15 service-vlan-format=untagged-or-tagged

When you configure a Mikrotik switch you're pretty much configuring the switch controller chip directly. Cisco's 'switchport mode trunk' hides all this under the hood.

  • Thanks for the info. What about the vlan config on RB750G (Atheros 8316)? That's where I had the most problem because it needs to do 802.1q, access ports, routing and DHCP. From packet capture it doesn't look like switch vlan was working correctly. I saw packets either going into a port not in the right vlan or CPU not receiving packets packets on the VLAN despite I put CPU port into the VLAN. – sdaffa23fdsf Feb 7 '16 at 22:11

Not the answer you're looking for? Browse other questions tagged or ask your own question.