3

We have got a three core switches:

ML1 - HP 5406zl (J8697A) firmware:K.15.14.0007

ML2 - HP 5406zl (J8697A) firmware:K.15.14.0007

ML3 - HP 5412zl (J8698A) firmware:K.15.16.0008

Recently I created 2 new VLANS (Vlan ID 200 - CISCO-WIFI-MGMT,201 - Cisco-WIFI-REDUNDANT) on all three core switches. After that Im unable to see any vlan with ID above 200 in VLAN menu -> Vlan port assignment menu on every core switch. Here is the VLAN config of core switch ML1 which is a primary gateway for all vlans (VRRP master)


vlan 1
   name "Default"
   no untagged A2-A16,A19,A21-A24,C3,C5-C19,D4-D8
   untagged A17-A18,A20,B1-B24,C20-C22,D1-D3,E1-E24
   tagged A1,C1-C2,C4
   ip address 10.20.2.155 255.255.0.0
   ip helper-address 10.16.0.1
   ip helper-address 10.16.0.2
   ip helper-address 10.20.9.32
   vrrp vrid 1
      virtual-ip-address 10.20.2.155
      priority 255
      enable
      exit
   exit
vlan 2
   name "Servus"
   tagged A1,B1-B24,C1-C3,C5-C9,C11-C12,C21-C22,D1-D8
   ip address 10.16.15.254 255.255.252.0
   vrrp vrid 2
      virtual-ip-address 10.16.15.254
      priority 255
      enable
      exit
   exit
vlan 3
   name "Office3"
   tagged A1,B1-B24,C1-C3,C5-C9,C11-C12,C21-C22,D1-D8
   ip address 10.16.19.254 255.255.252.0
   ip helper-address 10.16.0.1
   ip helper-address 10.16.0.2
   ip helper-address 10.20.9.32
   vrrp vrid 3
      virtual-ip-address 10.16.19.254
      priority 255
      enable
      exit
   exit
vlan 4
   name "Office4"
   tagged A1,B1-B24,C1-C3,C5-C9,C11-C12,C21-C22,D1-D8
   ip address 10.16.23.254 255.255.252.0
   ip helper-address 10.16.0.1
   ip helper-address 10.16.0.2
   ip helper-address 10.20.9.32
   vrrp vrid 4
      virtual-ip-address 10.16.23.254
      priority 255
      enable
      exit
   exit
vlan 5
   name "Office5"
   untagged A5-A8,A12
   tagged A1,B1-B24,C1-C3,C5-C9,C11-C12,C21-C22,D1-D8
   ip address 10.16.27.254 255.255.252.0
   ip helper-address 10.16.0.1
   ip helper-address 10.16.0.2
   ip helper-address 10.20.9.32
   vrrp vrid 5
      virtual-ip-address 10.16.27.254
      priority 255
      enable
      exit
   exit
vlan 6
   name "Office6"
   tagged A1,B1-B24,C1-C3,C5-C9,C11-C12,C21-C22,D1-D8
   ip address 10.16.31.254 255.255.252.0
   ip helper-address 10.16.0.1
   ip helper-address 10.16.0.2
   ip helper-address 10.20.9.32
   vrrp vrid 6
      virtual-ip-address 10.16.31.254
      priority 255
      enable
      exit
   exit
vlan 7
   name "Office7"
   tagged A1,B1-B24,C1-C3,C5-C9,C11-C12,C21-C22,D1-D8
   ip address 10.16.35.254 255.255.252.0
   ip helper-address 10.16.0.1
   ip helper-address 10.16.0.2
   ip helper-address 10.20.9.32
   vrrp vrid 7
      virtual-ip-address 10.16.35.254
      priority 255
      enable
      exit
   exit
vlan 8
   name "Office8"
   tagged A1,B1-B24,C1-C3,C5-C9,C11-C12,C21-C22,D1-D8
   ip address 10.16.39.254 255.255.252.0
   ip helper-address 10.16.0.1
   ip helper-address 10.16.0.2
   ip helper-address 10.20.9.32
   vrrp vrid 8
      virtual-ip-address 10.16.39.254
      priority 255
      enable
      exit
   exit
vlan 9
   name "Management"
   untagged A3-A4,A9,A22,C4-C6,C9,C11-C15,C17,C19
   tagged A1,B1-B24,C1-C3,C7-C8,C21-C22,D1-D8
   ip address 10.16.131.254 255.255.252.0
   ip helper-address 10.16.0.1
   ip helper-address 10.16.0.2
   vrrp vrid 9
      virtual-ip-address 10.16.131.254
      priority 255
      enable
      exit
   exit
vlan 10
   name "Server"
   untagged A1,C1-C3,C7-C8,C10,D4-D8
   tagged B1-B24,C21-C22,D1-D3
   ip address 10.16.3.254 255.255.252.0
   vrrp vrid 10
      virtual-ip-address 10.16.3.254
      priority 255
      enable
      exit
   exit
vlan 11
   name "Factory1"
   tagged A1,B1-B24,C1-C3,C5-C9,C11-C12,C21-C22,D1-D8
   ip address 10.16.43.254 255.255.252.0
   ip helper-address 10.16.0.1
   ip helper-address 10.16.0.2
   vrrp vrid 11
      virtual-ip-address 10.16.43.254
      priority 255
      enable
      exit
   exit
vlan 12
   name "Factory2"
   tagged A1,B1-B24,C1-C3,C5-C9,C11-C12,C21-C22,D1-D8
   ip address 10.16.47.254 255.255.252.0
   ip helper-address 10.16.0.1
   ip helper-address 10.16.0.2
   vrrp vrid 12
      virtual-ip-address 10.16.47.254
      priority 255
      enable
      exit
   exit
vlan 13
   name "Factory3"
   tagged A1,B1-B24,C1-C3,C5-C9,C11-C12,C21-C22,D1-D8
   ip address 10.16.51.254 255.255.252.0
   ip helper-address 10.16.0.1
   ip helper-address 10.16.0.2
   vrrp vrid 13
      virtual-ip-address 10.16.51.254
      priority 255
      enable
      exit
   exit
vlan 14
   name "Factory4"
   tagged A1,B1-B24,C1-C3,C5-C9,C11-C12,C21-C22,D1-D8
   ip address 10.16.55.254 255.255.252.0
   ip helper-address 10.16.0.1
   ip helper-address 10.16.0.2
   vrrp vrid 14
      virtual-ip-address 10.16.55.254
      priority 255
      enable
      exit
   exit
vlan 15
   name "Factory5"
   tagged A1,B1-B24,C1-C3,C5-C9,C11-C12,C21-C22,D1-D8
   ip address 10.16.59.254 255.255.252.0
   ip helper-address 10.16.0.1
   ip helper-address 10.16.0.2
   vrrp vrid 15
      virtual-ip-address 10.16.59.254
      priority 255
      enable
      exit
   exit
vlan 16
   name "Factory6"
   tagged A1,A16,B1-B24,C1-C3,C5-C9,C11-C12,C21-C22,D1-D8
   ip address 10.16.63.254 255.255.252.0
   ip helper-address 10.16.0.1
   ip helper-address 10.16.0.2
   vrrp vrid 16
      virtual-ip-address 10.16.63.254
      priority 255
      enable
      exit
   exit
vlan 17
   name "Factory7"
   tagged A1,B1-B24,C1-C3,C5-C9,C11-C12,C21-C22,D1-D8
   ip address 10.16.67.254 255.255.252.0
   ip helper-address 10.16.0.1
   ip helper-address 10.16.0.2
   vrrp vrid 17
      virtual-ip-address 10.16.67.254
      priority 255
      enable
      exit
   exit
vlan 18
   name "Factory8"
   tagged A1,B1-B24,C1-C3,C5-C9,C11-C12,C21-C22,D1-D8
   ip address 10.16.71.254 255.255.252.0
   ip helper-address 10.16.0.1
   ip helper-address 10.16.0.2
   vrrp vrid 18
      virtual-ip-address 10.16.71.254
      priority 255
      enable
      exit
   exit
vlan 19
   name "Factory9"
   tagged A1,B1-B24,C1-C3,C5-C9,C11-C12,C21-C22,D1-D8
   ip address 10.16.75.254 255.255.252.0
   ip helper-address 10.16.0.1
   ip helper-address 10.16.0.2
   vrrp vrid 19
      virtual-ip-address 10.16.75.254
      priority 255
      enable
      exit
   exit
vlan 20
   name "Maschinen"
   untagged A13-A15
   tagged A1,B1-B24,C1-C3,C5-C9,C11-C12,C21-C22,D1-D8
   ip access-group "engelmaschinen" in
   ip address 10.16.11.254 255.255.252.0
   vrrp vrid 20
      virtual-ip-address 10.16.11.254
      priority 255
      enable
      exit
   exit
vlan 22
   name "DMZ_MPLS"
   untagged A24
   tagged A1,A22,B1-B24,C1-C3,C5-C9,C11-C12,C21-C22,D1-D8
   no ip address
   exit
vlan 23
   name "dmz_engel_sk"
   untagged A2
   tagged A22,C21-C22
   no ip address
   exit
vlan 26
   name "DMZ"
   tagged A1,A22,B1-B24,C1-C3,C5-C9,C11-C12,C21-C22,D1-D8
   no ip address
   exit
vlan 30
   name "Transfer"
   untagged A21
   tagged C21-C22
   ip address 10.16.95.254 255.255.252.0
   vrrp vrid 30
      virtual-ip-address 10.16.95.254
      priority 255
      enable
      exit
   exit
vlan 55
   name "QS_Labor"
   tagged A1,B1-B24,C1-C3,C5-C9,C11-C12,C21-C22,D1-D8
   ip address 10.16.7.254 255.255.252.0
   vrrp vrid 55
      virtual-ip-address 10.16.7.254
      priority 255
      enable
      exit
   exit
vlan 90
   name "Dialin VPN"
   tagged A1,B1-B24,C1-C3,C5-C9,C11-C12,C21-C22,D1-D8
   no ip address
   exit
vlan 92
   name "Video"
   tagged A1,A22,B1-B24,C1-C3,C5-C9,C11-C12,C21-C22,D1-D8
   no ip address
   exit
vlan 96
   name "WLAN_ZKW"
   tagged A1,B1-B24,C1-C9,C11-C12,C21-C22,D1-D8
   ip address 10.16.107.254 255.255.252.0
   ip helper-address 10.16.0.1
   ip helper-address 10.16.0.2
   vrrp vrid 96
      virtual-ip-address 10.16.107.254
      priority 255
      enable
      exit
   exit
vlan 97
   name "WLAN_PSK"
   tagged A1,B1-B24,C1-C9,C11-C12,C21-C22,D1-D8
   ip address 10.16.111.254 255.255.252.0
   ip helper-address 10.16.0.1
   ip helper-address 10.16.0.2
   vrrp vrid 97
      virtual-ip-address 10.16.111.254
      priority 255
      enable
      exit
   exit
vlan 98
   name "Guest_LAN"
   tagged A1,A22,B1-B24,C1-C9,C11-C12,C21-C22,D1-D8
   ip address 10.16.115.100 255.255.252.0
   exit
vlan 99
   name "Voice"
   tagged A1-A12,A15,B1-B24,C1-C9,C11-C12,C21-C22,D1-D8
   ip address 10.16.99.254 255.255.252.0
   ip helper-address 10.16.0.1
   ip helper-address 10.16.0.2
   qos priority 5
   voice
   vrrp vrid 99
      virtual-ip-address 10.16.99.254
      priority 255
      enable
      exit
   exit
vlan 200
   name "Cisco-WIFI-MGMT"
   untagged A10-A11,C16,C18
   tagged C21-C22
   ip address 10.16.203.254 255.255.252.0
   ip helper-address 10.16.0.1
   ip helper-address 10.16.0.2
   vrrp vrid 200
      virtual-ip-address 10.16.203.254
      priority 255
      enable
      exit
   exit
vlan 201
   name "Cisco-WIFI-REDUNDANT"
   untagged A19
   tagged C21-C22
   no ip address
   exit
vlan 998
   name "TK_Internet"
   untagged A23
   tagged C21-C22,D2
   no ip address
   exit

show vlan output:


VLAN ID Name                             | Status     Voice Jumbo
  ------- -------------------------------- + ---------- ----- -----
  1       Default                          | Port-based No    No
  2       Servus                           | Port-based No    No
  3       Office3                          | Port-based No    No
  4       Office4                          | Port-based No    No
  5       Office5                          | Port-based No    No
  6       Office6                          | Port-based No    No
  7       Office7                          | Port-based No    No
  8       Office8                          | Port-based No    No
  9       Management                       | Port-based No    No
  10      Server                           | Port-based No    No
  11      Factory1                         | Port-based No    No
  12      Factory2                         | Port-based No    No
  13      Factory3                         | Port-based No    No
  14      Factory4                         | Port-based No    No
  15      Factory5                         | Port-based No    No
  16      Factory6                         | Port-based No    No
  17      Factory7                         | Port-based No    No
  18      Factory8                         | Port-based No    No
  19      Factory9                         | Port-based No    No
  20      Maschinen                        | Port-based No    No
  22      DMZ_MPLS                         | Port-based No    No
  23      dmz_engel_sk                     | Port-based No    No
  26      DMZ                              | Port-based No    No
  30      Transfer                         | Port-based No    No
  55      QS_Labor                         | Port-based No    No
  90      Dialin VPN                       | Port-based No    No
  92      Video                            | Port-based No    No
  96      WLAN_ZKW                         | Port-based No    No
  97      WLAN_PSK                         | Port-based No    No
  98      Guest_LAN                        | Port-based No    No
  99      Voice                            | Port-based Yes   No
  200     Cisco-WIFI-MGMT                  | Port-based No    No
  201     Cisco-WIFI-REDUNDANT             | Port-based No    No
  998     TK_Internet                      | Port-based No    No

Here is the screenshot of the vlan port assignment menu:

enter image description here

So as you can see that I can not see complete name of VLAN ID 200 (CISCO-WIFI-MGMT) and all the VLANS with higher ID than 200 which is for example VLAN 201 and 998 (CISCO-WIFI-REDUNDANT and TK_Internet) I do not know if I did some mistakes in my config or it is a firmware bug or some kind of HP limitation. At the moment I can not really perform a firmware upgrade of core switches or reboot them, can somebody suggest me what should I try to fix this issue ? I also tried to rename both new vlans and it was not helpful.

3
  • What makes you think this is a bug? This is pretty typical behavior. Even if it were a bug, we can't fix a vendor's bug for you, you need to contact the vendor.
    – Ron Maupin
    Feb 9 '16 at 8:33
  • It looks like your VLAN names are too long to be showed in the menu system. If you can't see VLANs with an ID higher than 200 at all then it's probably due to the total number of VLANS that can be shown in the menu. I'd recommend that you'd use the CLI instead to manage configurations of that size.
    – Stuggi
    Feb 9 '16 at 8:39
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer.
    – Ron Maupin
    Aug 13 '17 at 6:07
1

This isn't a bug. Firstly, yes, the VLAN names are too long to be shown in the Menu interface. Secondly, there's a limit on how many VLANs you can see in the menu in the first place - 32. Your VLAN 200 is the 32nd, so no new VLANs can be shown.

The Menu interface of ProCurve / ProVision switches is limited. Same applies to the Web GUI. Stuggi's right, you should get comfy with the CLI. That's the only interface with full management capabilities.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.