1

I've just moved into a new shared office and bought a Gigabit switch to add ethernet sockets to the network, in addition to having WiFi access from a shared wireless access point.

I've connected all devices up to the network and setup static IP's for each device. I haven't touched the wireless access point's configuration as it's shared for the office and I don't want to screw up anyone else's internet access.

Here's a quick diagram to show an overview of the office's network setup:

enter image description here

The problem I'm having is that no device on the network has internet access (except for devices connecting through the router). However, each device can communicate with each other if I ping one device from another.

What would be the best way of debugging this issue? I'm no genius when it comes to networking, but I know the basics. I need internet access from the NAS and as it's a wired device I can't access files from it remotely. I can connect to the internet through the shared wireless access point, but this kind of defeats me buying the additional hardware to setup the network like this.

I've tried messing around with ip configurations for hours, as well as contacting I.T support for the office space but they didn't know what was wrong and said just to use the Wifi. I have a feeling some sort of restriction may be in place higher up in the network which is out of my control which says only the router's mac address is allowed internet. Is this a possibility? Any advice would be appreciated!

closed as off-topic by Ron Maupin, Craig Constantine Feb 10 '16 at 16:06

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "NE is a site for to ask and provide answers about professionally managed networks in a business environment. Your question falls outside the areas our community decided are on topic. Please visit the help center for more details. If you disagree with this closure, please ask on Network Engineering Meta." – Ron Maupin, Craig Constantine
If this question can be reworded to fit the rules in the help center, please edit the question.

  • You said your devices have static IP addresses. Did you receive those addresses + subnet masks + default gateway from local IT? If not, you should get this information. And you could remove static address from one of the PC-s and let it get the address automatically - to see what's going on. – Muti Onu Feb 9 '16 at 16:14
  • And it would be interesting to check the IP configuration that is coming from the WIFI access point. – Muti Onu Feb 9 '16 at 16:21
  • 1
    "no device on the network has internet access (except for devices connecting through the router)" The problem with that statement is that I don't see a router anywhere on your drawing. Also, questions about networks not under your control are explicitly off-topic. – Ron Maupin Feb 9 '16 at 18:30
  • What was the network layout before you added lots of stuff? Is the Access Point actually just an access point (bridging), or is it a router, and in the latter case, is it using NAT? – jcaron Feb 10 '16 at 0:28
1

If all connected devices can conmmunicate each other, then you should see if you have put the default gateway in all your pcs. Also, if your switch are capable, can put some loopback interfaces in, eg, your gigabit switch 1, to troubleshoot from here to your network, and tried a ping test from here to your pc, notice that this ip address mus be in the same network of your equipment.

From here, you need to review your connectivity, and see if you are good with the distances for UTP(100 meters) and cable types used(crossover cables for the connections between switches)

0

You could try to remove all static IP addresses and let your PCs and NAS to get the IP address automatically. If there is a dhcp server, you should get the proper IP configuration together with the gateway address. If not, continue with IT support.

Not the answer you're looking for? Browse other questions tagged or ask your own question.