4

I´m experiencing a weird problem with a Catalyst 6509, 2XSUP7203BXL and 2XWS-X6704-10GE. After initial configuration with a static route, injecting packets or testing a ddos against my router, with 250-300 mbit and 50.000 packets or even less in Tengigabit interfaces, it starts to increase cpu usage and it is freezed in 10 seconds, more or less. Checking cpu usage, IP INPUT is using all the time of cpu, i think it is software switched, is it correct?

I tried upgrading ios to 15.1, downgrading IOS to 12.2 (2009 version) and with IOS 12.2 (September 2014) and moved fiber to another 6704-10GE card with no luck, same behaviour in another module. My cards are installed in SLOT 1 and Slot 4, i heard about of limitations in 6513 but not in 6509.

Some info:

Cisco IOS Software, s72033_rp Software (s72033_rp-ADVENTERPRISEK9_WAN-M), Version 12.2(33)SXI14, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2014 by Cisco Systems, Inc.
Compiled Thu 04-Sep-14 00:37 by prod_rel_team

ROM: System Bootstrap, Version 12.2(17r)SX7, RELEASE SOFTWARE (fc1)

cisco WS-C6509-E (R7000) processor (revision 1.4) with 983008K/65536K bytes of memory.
Processor board ID SMG1133N5U1
SR71000 CPU at 600Mhz, Implementation 0x504, Rev 1.2, 512KB L2 Cache
Last reset from s/w reset
3 Virtual Ethernet interfaces
148 Gigabit Ethernet interfaces
8 Ten Gigabit Ethernet interfaces
1917K bytes of non-volatile configuration memory.
8192K bytes of packet buffer memory.

65536K bytes of Flash internal SIMM (Sector size 512K).
Configuration register is 0x2102

#show module
Mod Ports Card Type Model Serial No.
--- ----- -------------------------------------- ------------------ -----------
1 4 CEF720 4 port 10-Gigabit Ethernet WS-X6704-10GE SAD104209JK
2 24 CEF720 24 port 1000mb SFP WS-X6724-SFP SAL14523JKH
3 24 CEF720 24 port 1000mb SFP WS-X6724-SFP SAL10499QHT
4 4 CEF720 4 port 10-Gigabit Ethernet WS-X6704-10GE SAL1249C9L5
5 2 Supervisor Engine 720 (Active) WS-SUP720-3BXL SAD084301NF
6 2 Supervisor Engine 720 (Hot) WS-SUP720-3BXL SAD083400TH
7 48 CEF720 48 port 10/100/1000mb Ethernet WS-X6748-GE-TX SAL09518H8V
8 48 CEF720 48 port 10/100/1000mb Ethernet WS-X6748-GE-TX SAL13410ULX

Mod MAC addresses Hw Fw Sw Status
--- ---------------------------------- ------ ------------ ------------ -------
1 0019.5671.290e to 0019.5671.2911 2.4 12.2(14r)S5 12.2(33)SXI1 Ok
2 e05f.b972.c5f4 to e05f.b972.c60b 5.0 12.2(18r)S1 12.2(33)SXI1 Ok
3 0019.aa6f.90d8 to 0019.aa6f.90ef 2.5 12.2(14r)S5 12.2(33)SXI1 Ok
4 0021.a07f.3b54 to 0021.a07f.3b57 2.7 12.2(14r)S5 12.2(33)SXI1 Ok
5 0011.21ba.6ea4 to 0011.21ba.6ea7 4.0 8.5(4) 12.2(33)SXI1 Ok
6 0011.21a1.185c to 0011.21a1.185f 4.0 8.5(4) 12.2(33)SXI1 Ok
7 0016.46e8.a6b8 to 0016.46e8.a6e7 2.3 12.2(14r)S5 12.2(33)SXI1 Ok
8 0027.0da7.ecd0 to 0027.0da7.ecff 3.2 12.2(18r)S1 12.2(33)SXI1 Ok

Mod Sub-Module Model Serial Hw Status
---- --------------------------- ------------------ ----------- ------- -------
1 Distributed Forwarding Card WS-F6700-DFC3BXL SAD11070CG8 5.3 Ok
2 Centralized Forwarding Card WS-F6700-CFC SAL145132LL 4.1 Ok
3 Centralized Forwarding Card WS-F6700-CFC SAL1030WL08 3.0 Ok
4 Distributed Forwarding Card WS-F6700-DFC3BXL SAD090303ZF 3.0 Ok
5 Policy Feature Card 3 WS-F6K-PFC3BXL SAD081006SX 1.3 Ok
5 MSFC3 Daughterboard WS-SUP720 SAD0836078V 2.1 Ok
6 Policy Feature Card 3 WS-F6K-PFC3BXL SAD08330B2V 1.3 Ok
6 MSFC3 Daughterboard WS-SUP720 SAD08320JKD 2.1 Ok
7 Centralized Forwarding Card WS-F6700-CFC SAL100193VC 2.0 Ok
8 Centralized Forwarding Card WS-F6700-CFC SAL1338YXD0 4.1 Ok

Mod Online Diag Status
---- -------------------
1 Pass
2 Pass
3 Pass
4 Pass
5 Pass
6 Pass
7 Pass
8 Pass

#show platform hardware pfc mode
PFC operating mode : PFC3BXL

#show platform hardware capacity
System Resources
PFC operating mode: PFC3BXL
Supervisor redundancy mode: administratively sso, operationally sso
Switching resources: Module Part number Series CEF mode
1 WS-X6704-10GE CEF720 dCEF
2 WS-X6724-SFP CEF720 CEF
3 WS-X6724-SFP CEF720 CEF
4 WS-X6704-10GE CEF720 dCEF
5 WS-SUP720-3BXL supervisor CEF
6 WS-SUP720-3BXL supervisor CEF
7 WS-X6748-GE-TX CEF720 CEF
8 WS-X6748-GE-TX CEF720 CEF

Power Resources
Power supply redundancy mode: administratively redundant
operationally redundant
System power: 2771W, 0W (0%) inline, 2513W (91%) total allocated
Powered devices: 0 total, 0 Class3, 0 Class2, 0 Class1, 0 Class0, 0 Cisco

Flash/NVRAM Resources
Usage: Module Device Bytes: Total Used %Used
1 dfc#1-bootflash: 15990784 0 0%
2 dfc#2-bootflash: 15990784 0 0%
3 dfc#3-bootflash: 15990784 0 0%
4 dfc#4-bootflash: 15990784 0 0%
5 RP bootflash: 65536000 0 0%
5 SP sup-bootdisk: 512106496 343056384 67%
5 SP const_nvram: 129004 676 1%
5 SP nvram: 1964024 18464 1%
6 slavenvram: 1964024 19488 1%
6 slaveconst_nvram: 129004 676 1%
6 slavesup-bootdisk: 512024576 343040000 67%
6 slavebootflash: 65536000 16796472 26%
7 dfc#7-bootflash: 15990784 0 0%
8 dfc#8-bootflash: 15990784 0 0%

configuration is:

upgrade fpd auto version 12.2 
service timestamps 
debug datetime msec 
service timestamps 
log datetime msec 
service password-encryption 
service counters max age 5 
no service dhcp 
! 
hostname ipcore6509e 
! 
boot-start-marker 
boot system sup-bootflash:s72033-adventerprisek9_wan-mz.122-33.SXI14.bin 
boot system sup-bootflash:s72033-adventerprisek9-mz.151-1.SY1.bin 
boot-end-marker aaa new-model 
! 
aaa session-id common 
clock timezone Spain 1 
no ip domain-lookup 
udld enable
no mls acl 
tcam share-global 
mls netflow interface 
mls cef error action freeze 
mls cef maximum-routes ip 768 
!
spanning-tree mode pvst 
diagnostic bootup level minimal 
!
redundancy main-cpu auto-sync running-config mode sso !
vlan internal allocation policy ascending vlan access-log ratelimit 2000
!
interface TenGigabitEthernet4/1 
 switchport 
 switchport trunk encapsulation dot1q 
 switchport trunk allowed vlan 110 
 switchport mode trunk
!
interface Vlan90 
 description vlan management 
 ip address 10.67.95.1 255.255.255.0 
 shutdown 
! 
interface Vlan110 
 description adamo uplink 10g 
 ip address myuplink 255.255.255.252 
 no ip redirects 
 no ip unreachables 
 no ip route-cache 
! 
router bgp myas 
 no synchronization 
 bgp log-neighbor-changes 
 bgp graceful-restart restart-time 120 
 bgp graceful-restart stalepath-time 360 
 bgp graceful-restart 
 neighbor myupstream remote-as 35699 
 no auto-summary 
! 
ip classless 
ip forward-protocol nd 
ip route 0.0.0.0 0.0.0.0 mygateway 
! 
no ip http server 
no ip http secure-server 
! 
control-plane 
! 
dial-peer cor custom 
! 
line con 0 
line vty 0 4 
 transport input ssh 
line vty 5 15 
 transport input all 
!
ntp clock-period 17179928 
ntp server 130.206.3.166 
! 
end

and show process cpu example:

CPU utilization for five seconds: 18%/3%; one minute: 8%; five minutes: 9% 327 103416 21228 4871 0.07% 27.33% 13.07% 0 IP Input
  • You don't actually provide enough detail, although the detail you provided is useful. Please edit your question to add the full device configuration (you can sanitize any public addresses), and the output from the show processes cpu command when the problem starts would be useful, too. – Ron Maupin Feb 12 '16 at 23:32
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer. – Ron Maupin Aug 13 '17 at 6:23
2

If you are sending packets toward IP addresses of the device, it will need to handle those packets in the CPU.

Consider enabling CoPP: http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst6500/ios/12-2SX/configuration/guide/book/copp.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.