9

I've got a catalyst 2960G, connected to a Netgear Prosafe GS718T switch (cheap manageable switch). Idea is I have a couple of users that need access to a test environment - hence the cheap switch. It's connected via fibre through a 1Gbit SFP over multimode, layer 1 looks ok, interface on the catalyst and the netgear are both up/up, but I can't get any traffic over it.

The int on the 2960G is configured as default except it's in access mode (tried it with DTP on - doesn't work) on a specific VLAN, and the netgear is in it's default config, so it should just be acting as a dumb switch with no tagging on the link to the cat. However I do a #sh mac address table on the cat and it doesn't return anything against the interface facing the netgear, and I try to ping to a good IP at the cat end from the netgear end and get nothing. Again interfaces are all up/up and the cat isn't blocking multiple mac addresses of one port (ie no port-security).

Anyone else tried to use on of these Netgear GS switches with a cisco switch or similar over it's fibre int and got it working? The web interface is horrible, been trying to see if I can do anything in it, really want to avoid trunking it if I can as it's not needed and it looks like a real hassle on the netgear. Ideally I'd be using another catalyst but we've got none spare, and this netgear is meant to support all the ethernet standards.

  • 6
    @MikePennington, just to clarify, the Netgear Prosafe line of devices is considered small business and has the option of paid support and/or maintenance through Netgear. While I wouldn't personally use these products in an enterprise, I don't think we can call them consumer devices. – YLearn Aug 7 '13 at 16:40
  • 1
    Agreed... pro-sumer is a better term... I stand corrected, thanks for pointing that out – Mike Pennington Aug 7 '13 at 16:50
  • 1
    Have you tried using a cross-over cable between the 2960G and the Netgear? I haven't had much experience with the Netgear line of switches, but back in the day when we migrated from 3COM to Cisco we had some closets that we had to use cross-over cables from a Cisco switch to a 3Com. The port itself on the Cisco was then set to Access. – infinisource Aug 7 '13 at 17:22
  • 2
    @infinisource, since he is talking about fiber and has link, the fiber is already crossed properly. With fiber, if you were matched TX/TX, you wouldn't get link. – YLearn Aug 7 '13 at 17:49
  • 1
    What are the spanning-tree tools showing on each end? Mixing Cisco and non-Cisco STP can require tweaking. – chrylis -cautiouslyoptimistic- Aug 7 '13 at 20:35
2

Fixed! Turns out, after slagging off the netgear, it was the cisco that was causing the problem. Seems when I configured the interface switchport access vlan 20 it didn't create vlan 20 on the switch automatically like it would normally.

Found it by doing a sh trunkand VLAN 20 wasn't included in any of the trunks, did a sh vlan and it wasn't listed either, so created it and all working. Very odd.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.