6

I've a CPE connected to a 4506 switch. The interface is Up but I don't see traffic CPE MAC address on MAC sddes-table

I've already replaced the cable, SFP and port. Now I've the minimal config (nothing i.e. switchport access) and no MAC yet.

4506-1#sh int gi2/3
GigabitEthernet2/3 is up, line protocol is up (connected) 
  Hardware is Gigabit Ethernet Port, address is XXXX.XX7b.c407 (bia XXXX.XX7b.c407)
  MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, link type is force-up, media type is 1000Base-2BX10-D
  input flow-control is on, output flow-control is on 
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters 00:13:11
  Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     444 packets input, 200910 bytes, 0 no buffer
     Received 446 broadcasts (0 multicasts)
     0 runts, 0 giants, 0 throttles 
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     463 packets output, 35901 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

4506-1#sh mac address-table 
Unicast Entries
 vlan     mac address     type        protocols               port
---------+---------------+--------+---------------------+-------------------------
   1      XXXX.XX43.23ad   dynamic ip,ipx,assigned,other TenGigabitEthernet1/1      
   1      XXXX.XX43.23ad   dynamic ip,ipx,assigned,other TenGigabitEthernet1/1      
1100      XXXX.XX6a.2548   dynamic ip,ipx,assigned,other TenGigabitEthernet1/1      
1100      XXXX.XXa1.6f3f   dynamic ip,ipx,assigned,other TenGigabitEthernet1/1      
1100      XXXX.XXa1.7b7f   dynamic ip,ipx,assigned,other TenGigabitEthernet1/1      
1100      XXXX.XX48.fabf    static ip,ipx,assigned,other Switch                     
1110      XXXX.XX07.ac01   dynamic ip,ipx,assigned,other TenGigabitEthernet1/1      
1111      XXXX.XX07.ac01   dynamic ip,ipx,assigned,other TenGigabitEthernet1/1      
1111      XXXX.XXa1.6f3f   dynamic ip,ipx,assigned,other TenGigabitEthernet1/1      
1112      XXXX.XX07.ac01   dynamic ip,ipx,assigned,other TenGigabitEthernet1/1      
1112      XXXX.XXa1.6f3f   dynamic ip,ipx,assigned,other TenGigabitEthernet1/1      
1120      XXXX.XX07.ac01   dynamic ip,ipx,assigned,other TenGigabitEthernet1/1      
1120      XXXX.XXa1.7b7f   dynamic ip,ipx,assigned,other TenGigabitEthernet1/1      
1121      XXXX.XX07.ac01   dynamic ip,ipx,assigned,other TenGigabitEthernet1/1      
1121      XXXX.XXa1.7b7f   dynamic ip,ipx,assigned,other TenGigabitEthernet1/1      
1122      XXXX.XX07.ac01   dynamic ip,ipx,assigned,other TenGigabitEthernet1/1      
1122      XXXX.XXa1.7b7f   dynamic ip,ipx,assigned,other TenGigabitEthernet1/1      

4506-1#sh mac address-table int gi2/3
Multicast Entries
 vlan      mac address     type    ports
---------+---------------+-------+--------------------------------------------
   1      ffff.ffff.ffff   system Gi2/3,Te1/1

SFP is 1000Base-2BX10-D and I check the specifications. I saw the operation range for the SFP is RX: -3 to -19.5 and TX: -3 to -9. When I type the command,

4506-1#sh int gi2/1 transceiver 
ITU Channel not available (Wavelength not available),
Transceiver is internally calibrated.
If device is externally calibrated, only calibrated values are printed.
++ : high alarm, +  : high warning, -  : low warning, -- : low alarm.
NA or N/A: not applicable, Tx: transmit, Rx: receive.
mA: milliamperes, dBm: decibels (milliwatts).

                                 Optical   Optical
           Temperature  Voltage  Tx Power  Rx Power
Port       (Celsius)    (Volts)  (dBm)     (dBm)
---------  -----------  -------  --------  --------
Gi2/1        36.3       3.25      -6.1     -22.0  

So I think this is related with Fiber Optic link but the packets counters are incrementing.

ADD info :

Patched cable of 3M cable due to specification. Problem not solved.

Output of debug platform packet all int gi2/2

*Aug 12 03:30:03.803: Tx packet to Port Gi2/2 Vlan Tag 1 FwdVlan 1 CoS 7 TagType No   Tag Src XX:XX:XX:7B:C4:06 Dst 01:80:C2:00:00:00 Type/Len 0x0026 Length 60  
*Aug 12 03:30:05.802: Tx packet to Port Gi2/2 Vlan Tag 1 FwdVlan 1 CoS 7 TagType No   Tag Src XX:XX:XX:7B:C4:06 Dst 01:80:C2:00:00:00 Type/Len 0x0026 Length 60  
*Aug 12 03:30:07.802: Tx packet to Port Gi2/2 Vlan Tag 1 FwdVlan 1 CoS 7 TagType No    Tag Src XX:XX:XX:7B:C4:06 Dst 01:80:C2:00:00:00 Type/Len 0x0026 Length 60  
*Aug 12 03:30:09.802: Tx packet to Port Gi2/2 Vlan Tag 1 FwdVlan 1 CoS 7 TagType No   Tag Src XX:XX:XX:7B:C4:06 Dst 01:80:C2:00:00:00 Type/Len 0x0026 Length 60  
  • What is the CPE on the other end? Have you checked on the other end if the link shows up? The port is in "force-up" state, why is that? Also please show the interface configuration. – Sebastian Wiesinger Aug 9 '13 at 12:22
  • I don't know what mean and why this state. I change the port and now is auto. – cgasp Aug 9 '13 at 12:52
  • I'm curious what those received frames are. Could link be looped? Maybe try 'debug plat packet all int gi2/3 receive', or debug mac learning (can't remember command, sorry) or use SPAN. – ytti Aug 9 '13 at 13:33
  • Update info. Yeah It's strange the packet incrementing. Sebastian, for tshoot I've a simple config switchport access, nothing special. ytti, span would be good to use for tshoot. I will try monday. – cgasp Aug 9 '13 at 15:19
  • Is the linecard WS-X4640-CSFP-E specifically, no other linecard supports 2BX optics. And CPE has BX optic? – ytti Aug 13 '13 at 14:09
5

You're not getting adequate signal for the receiver: -22 when it wants at least -19.5 dBm. Could be a bad/dirty connector, fiber trouble, etc.

My immediate suspicion is, however, the bone-simple one. I notice you are using a 1000Base-2BX10-D - is the other end also a 1000Base-2BX10-D, or is is it a 1000Base-2BX10-U? The two types must be used in pairs, one D (downlink) the other U (uplink) - the same type of single-fiber SFP is sometimes tagged A and B from other makers - they are also generally color-coded.

Since they work over one fiber by transmitting at one wavelength and receiving on a different one the transmitter on one end must match the receiver on the other, and vice versa. If both are sending on 1490 and listening on 1310, nothing works. Likewise, if one is transmitting on 1310 and listening on 1490, while the other is transmitting on 1490 and listening on 1550, the link won't work, even though one direction matches. You need one D transmitting on 1490 and listening on 1310 while the other U transmits on 1310 and listens on 1490 (more generally, for different Bi-Directional pairs, substitute in any matching set of wavelengths - 1550/1490, etc.)

Presumably the "wavelength not available" message relates to the excessively low signal on the receiver.

  • You wouldn't face 2BX with 2BX, you'd face it with normal BX in two different sites, otherwise fully agreed on the D/U, but if it were D/U mismatch we shouldn't see link up nor receive frames. – ytti Aug 10 '13 at 9:19
  • Then we get back to fiber issues - having swapped fibers as well as interfaces, look for damage at an endface that hasn't been changed, or something like a multimode patchcord on a singlemode link...something is eating a lot of signal. – Ecnerwal Aug 11 '13 at 13:01
  • No issue possible with D/U mismatch because it's a FTTH CPE - 4506 and by the specification the SFP is adequate so there is an issue with the fiber itself. – cgasp Aug 12 '13 at 4:47
  • The problem is the length of Cable. Page 3 on specification they said the minimum length is 2M I've only 1M :S, so here the issue. I will confirm this and come back with a feedback. Thanks for yours answers. – cgasp Aug 12 '13 at 5:27
  • 3M cable doesn't solve the issue. Add info on question. – cgasp Aug 12 '13 at 8:42
2

After reading the specification of SFP, I change the fiber cable and the issue persist. I check the two sides (SFP and CPE), both are sending packet and the counters are incrementing. So a colleague suggest this probably it's the negotiation (speed/duplex). I configure the speed on no-negotiate, strangely I can set a numerical speed (100/1000/...) as other switchs, only Auto or Nonegotiate. I set too the duplex on full, the problem persist. I contact our supplier of CPE Packetfront. We tried to tshoot the link. After a while and reading the Release Note of CPE we found there is improvements on firmware on negotiation with Cisco equipment, so he strongly recommend to upgrade version to the last version (1.10). Update done the CPE works fine. Thanks all for the support.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.