1

I'm config access-list on Cisco Router and this information is not show with SNMP.

step 1 : Config access-list and [show access-list]!
enter image description here

step 2 : I use CISCO-ACL-MIB With "iReasoning MIB Browser" i'm connected to device and not get output from access-list.
enter image description here

*I use GNS3 and my Configration:

R1#show running-config  
Building configuration...  

Current configuration : 1684 bytes  
!  
version 12.4  
service timestamps debug datetime msec  
service timestamps log datetime msec  
no service password-encryption  
!  
hostname R1  
!  
boot-start-marker  
boot-end-marker  
!  
!  
no aaa new-model  
memory-size iomem 5  
no ip icmp rate-limit unreachable  
!  
ip cef  
no ip domain lookup  
!  
!  
ip tcp synwait-time 5  
!  
interface FastEthernet0/0  
!  
interface FastEthernet0/1  
!  
 serial restart-delay 0  
!  
interface Vlan1  
 ip address 172.16.98.63 255.255.255.0  
!  
router ospf 1  
 log-adjacency-changes  
 network 10.0.0.0 0.255.255.255 area 1  
!  
no ip http server  
no ip http secure-server  
!
access-list 10 deny   10.0.0.0 0.255.255.255  
access-list 122 deny   icmp 10.0.0.0 0.255.255.255 host 1.1.1.24 echo-reply  
snmp-server community public RW  
no cdp log mismatch duplex  
!  
control-plane  
! 
line con 0  
 exec-timeout 0 0  
 privilege level 15  
 logging synchronous  
line aux 0  
 exec-timeout 0 0  
 privilege level 15  
 logging synchronous  
line vty 0 4  
 login  
!  
!  
end  
  • do you enable snmp on router? Can you get any information from router via snmp without using this mib? – Paul Feb 15 '16 at 17:49
  • please post the SNMP portion of your configuration, and details of the network path between your computer where you are trying to pull SNMP details to this device where you're trying to pull these details from. – skrap3e Feb 15 '16 at 20:41
  • @Paul Yes, I did enable SNMP on router and get any information from router with another MIB. – M. Rostami Feb 16 '16 at 7:59
  • @lasersauce Post edited and my network in GNS3 Lab. – M. Rostami Feb 16 '16 at 8:27
2

A lot of the time when you come across MIBs not populating, its simply because the MIB package is not compatible with the version of IOS that is running.

If you take a look at this Cisco tool http://tools.cisco.com/ITDIT/MIBS/MainServlet you can see which MIBs are compatible with your version of IOS.

For example, if you search for a C3725 running ADVSECURITYK9-M, Version 12.4(3) you wont see "CISCO-ACL-MIB", and consequently when I load that MIB up, I am unable to grab any information from the router.

IOS Info

R3#sh ver
Cisco IOS Software, 3700 Software (C3725-ADVSECURITYK9-M), Version 12.4(3), RELEASE SOFTWARE (fc2)


ROM: ROMMON Emulation Microcode
ROM: 3700 Software (C3725-ADVSECURITYK9-M), Version 12.4(3), RELEASE SOFTWARE (fc2)

R3 uptime is 19 minutes
System returned to ROM by unknown reload cause - suspect boot_data[BOOT_COUNT] 0x0, BOOT_COUNT 0, BOOTDATA 19

----snip-----

Cisco 3725 (R7000) processor (revision 0.1) with 124928K/6144K bytes of memory.
Processor board ID FTX0945W0MY
R7000 CPU at 240MHz, Implementation 39, Rev 2.1, 256KB L2, 512KB L3 Cache
4 FastEthernet interfaces
DRAM configuration is 64 bits wide with parity enabled.
55K bytes of NVRAM.
1024K bytes of ATA System CompactFlash (Read/Write)

Configuration register is 0x2102

SNMP/Access List Configuration

ip access-list extended TestName
 permit ip any any
!
access-list 90 permit any
snmp-server community test RO 90

iReasoning MIB Browser

enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.