2

Ok people, same drill on router-on-stick inter-vlan routing between a Cisco router and Cisco switch. Except this time, it's the expensive Nexus instead of Catalyst.

2911#show vlans

Virtual LAN ID:  1 (IEEE 802.1Q Encapsulation)

   vLAN Trunk Interface:   GigabitEthernet0/2

 This is configured as native Vlan for the following interface(s) :
GigabitEthernet0/2

   Protocols Configured:   Address:              Received:        Transmitted:
        Other                                           0                7772

   1431 packets, 403183 bytes input
   7772 packets, 551049 bytes output

Virtual LAN ID:  100 (IEEE 802.1Q Encapsulation)

   vLAN Trunk Interface:   GigabitEthernet0/2.100

   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.0.0.1                     2                   3
        Other                                           0                  13

   2 packets, 128 bytes input
   16 packets, 1798 bytes output

Virtual LAN ID:  200 (IEEE 802.1Q Encapsulation)

   vLAN Trunk Interface:   GigabitEthernet0/2.200

   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.1.0.1                     0                   3
        Other                                           0                  28

   0 packets, 0 bytes input
   31 packets, 2488 bytes output

This is my 2911 router interface.

!
interface GigabitEthernet0/2
 no ip address
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface GigabitEthernet0/2.100
 encapsulation dot1Q 100
 ip address 10.0.0.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface GigabitEthernet0/2.200
 encapsulation dot1Q 200
 ip address 10.1.0.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!

This is one of nexus trunk interface and vlan output.

interface Ethernet1/48
  switchport mode trunk

interface Vlan100
  no shutdown
  ip address 10.1.0.13/24

interface Vlan200
  no shutdown
  ip address 10.0.0.13/24

But 2911 and Nexus still can't ping each other's vlan inter ip.

What am I doing wrong or missing that's necessary in addition to what we usually do on a Catalyst?

Thanks.

[Update: After Ron M's catch]

C#          ping 10.0.0.1
PING 10.0.0.1 (10.0.0.1): 56 data bytes
64 bytes from 10.0.0.1: icmp_seq=0 ttl=254 time=0.804 ms
64 bytes from 10.0.0.1: icmp_seq=1 ttl=254 time=0.57 ms
64 bytes from 10.0.0.1: icmp_seq=2 ttl=254 time=0.534 ms
64 bytes from 10.0.0.1: icmp_seq=3 ttl=254 time=0.536 ms
64 bytes from 10.0.0.1: icmp_seq=4 ttl=254 time=0.526 ms

--- 10.0.0.1 ping statistics ---
5 packets transmitted, 5 packets received, 0.00% packet loss
round-trip min/avg/max = 0.526/0.593/0.804 ms
C#          ping 10.1.0.1
PING 10.1.0.1 (10.1.0.1): 56 data bytes
64 bytes from 10.1.0.1: icmp_seq=0 ttl=254 time=0.769 ms
64 bytes from 10.1.0.1: icmp_seq=1 ttl=254 time=0.56 ms
64 bytes from 10.1.0.1: icmp_seq=2 ttl=254 time=0.534 ms
64 bytes from 10.1.0.1: icmp_seq=3 ttl=254 time=0.522 ms
64 bytes from 10.1.0.1: icmp_seq=4 ttl=254 time=0.53 ms
1

VLAN 100 is on different networks in the two devices:

2911 is 10.0.0.0/24:

interface GigabitEthernet0/2.100
 encapsulation dot1Q 100
 ip address 10.0.0.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!

Nexus is 10.1.0.0/24:

interface Vlan100
  no shutdown
  ip address 10.1.0.13/24

VLAN 200 is on different networks in the two devices:

2911 is 10.1.0.0/24:

interface GigabitEthernet0/2.200
 encapsulation dot1Q 200
 ip address 10.1.0.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!

Nexus is 10.0.0.0/24:

interface Vlan200
  no shutdown
  ip address 10.0.0.13/24

Also, you don't want ip nat inside on interface GigabitEthernet0/2 since it doesn't have an IP address. You only need it on the subinterfaces.

  • Thanks and please see update. I can be so stupid, so sometimes I'm glad we have each other to proof-read. – opensourceworker Feb 18 '16 at 16:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.