2

I am having trouble configuring pfSense to accept the OSPF routing tables of attached routers. Any advice would be appreciated!

I have installed the Quagga OSPFd package, but I am not certain it is configured correctly at all.

All OSPF tables are being updated and shared amongst all connected routers. It is just the final hop between the last router and pfSense. The directly connected router is capable of pinging pfSense, and pfSense is capable of pinging the routers. However, none of the other routers are able to receive a response if they ping the firewall.

I am happy to go either one of two directions:

  1. Find a way for the directly connected router to share all of its routing information with pfSense, and exclude pfSense from OSPF.

  2. Configure OSPF on pfSense.

Note: If it would be helpful, I can screenshot in some pfSense information.

The following is the code from Router2 which is directly attached to pfSense:


interface GigabitEthernet0/0
 description PrimaryWANDesc_
 ip address 192.168.200.5 255.255.255.252
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 192.168.13.115 255.255.255.0
 duplex auto
 speed auto
!
router ospf 10
 network 150.10.93.0 0.0.0.255 area 0
 network 192.168.13.0 0.0.0.255 area 0
 network 192.168.200.4 0.0.0.3 area 0
!
ip forward-protocol nd
!
ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/1 192.168.30.1 110

Thank you again in advance,

  • There are a bunch of links if you search for pfsense ospf. This one makes it seem pretty simple. There are others on the pfSense forum, including about using Quagga. – Ron Maupin Feb 22 '16 at 2:21
  • By the way, you can insert screen shots in your question. Use the little picture icon next to the {} icon you use for code and configurations. Just don't do it for normal text things like the Cisco configurations. – Ron Maupin Feb 22 '16 at 2:38
  • Did any answer help you? if so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer. – Ron Maupin Aug 7 '17 at 19:41
2

After a bit more searching I discovered a few more links (thanks to Ron above for one of them) that helped clarify how to run OSPF on pfSense. Specifically, for my purposes, how to have have the pfSense box share its routing table and paths with all other routers within your network. (Note: Assuming user is familiar with OSPF)

The first step is to download the Quagga OSPFd package to pfSense. (I was running pfSense v. 2.2.4)

Once the package installs, look for it under services

The first tab under OSPFd, is the Global Settings. Here all you need to do (minimum) is to set the Router ID to the pfSense WAN address) and then set the area to 0.0.0.0.

enter image description here

Under the next tab, add the WAN and the LAN interface.

enter image description here

Here, we are just configuring the WAN address. By setting the 'interface' to the WAN interface, and once again set the area to 0.0.0.0.

enter image description here

This worked for me, hope someone will find it useful.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.