2

LACP between a R1-2210 VRTX 10Gb Switch & Cisco 3650 Stack will not bundle properly. Has anybody seen this/have any ideas? Running what is currently the latest firmware on the VRTX Switch and CAT3K_CAA-UNIVERSALK9-M on the Stack. As a side note- we do have LACP bundles between Dell 630s that are working fine.

Configs:

R1-2210 VRTX 10Gb Switch:

!
interface tengigabitethernet0/1
  channel-group 4 mode auto
  switchport mode trunk
!
interface tengigabitethernet0/2
  channel-group 4 mode auto
  switchport mode trunk
!
interface Port-channel4
 description LINK_TO_CORE
 switchport mode trunk
!
#show lacp protocol-state te0/1
LACP State Machines:
          Receive FSM:           Defaulted State
          Mux FSM:               Collecting Distributing State
          Periodic Tx FSM:       Slow Periodic State
  Control Variables:
          BEGIN:                 FALSE
          LACP_Enabled:          TRUE
          Ready_N:               FALSE
          Selected:              SELECTED
          Port_moved:            FALSE
          NNT:                   FALSE
          Port_enabled:          TRUE
  Timer counters:
          periodic tx timer:     22
          current while timer:   0
          wait while timer:      0
!
#show lacp protocol-state te0/2
 LACP State Machines:
          Receive FSM:           Defaulted State
          Mux FSM:               Detached State
          Periodic Tx FSM:       Slow Periodic State
  Control Variables:
          BEGIN:                 FALSE
          LACP_Enabled:          TRUE
          Ready_N:               FALSE
          Selected:              UNSELECTED
          Port_moved:            FALSE
          NNT:                   FALSE
          Port_enabled:          TRUE
  Timer counters:
          periodic tx timer:     14
          current while timer:   0
          wait while timer:      0
!
#show lacp statistics te0/1 (Same output on te0/2)
te0/1 LACP statistics:
  LACP Pdus sent:                45
  LACP Pdus received:            0
!
#show lacp Port-Channel 4
Port Type 10 Gigabit Ethernet
   Attached Lag id:
   Actor
           System Priority:1
           MAC Address:    f8:b1:56:74:c3:f1
           Admin Key:      1003
           Oper Key:       1003
   Partner
           System Priority:0
           MAC Address:    00:00:00:00:00:00
           Oper Key:       0

Cisco 3650 Stack:

!
interface Port-channel4
 description LINK TO VRTX TE1-2
 switchport mode trunk
!
interface GigabitEthernet2/1/4
 switchport mode trunk
 channel-protocol lacp
 channel-group 4 mode active
!
interface GigabitEthernet3/1/4
 switchport mode trunk
 channel-protocol lacp
 channel-group 4 mode active
!
#sho ether sum
4      Po4(SD)         LACP      Gi2/1/4(I)  Gi3/1/4(I)
!
#sho int po4
Port-channel4 is down, line protocol is down (notconnect)

Configurations are identical on our functioning Port Channels to our Dell 630s.

I appreciate any insight from the community.

Thanks for your time!

Chris.

  • Are these connected with copper connections? Try to shut down all three interfaces (including the port channel interface) on the Cisco, then bring them up int the order you have in your question: port channel, then the physical interfaces. – Ron Maupin Feb 26 '16 at 17:17
  • These are fiber connections. I have also tried setting the VRTX Switch to negotiate 1gig/full dplx. After shutting down all interfaces and bringing them up in the said order- the ports are still in stand-alone. – Christopher Dallas Feb 26 '16 at 17:52
  • I don't think you can mix 1 Gb and 10 Gb connections on fiber. You need to get the 10 Gb NM module for the Cisco 3650. – Ron Maupin Feb 26 '16 at 18:03
  • I don't know of any fiber transceivers which can change speeds. A 10 Gb fiber transceiver can do only 10 Gb. The 10 Gb Cisco NM module can use either 1 Gb or 10 Gb fiber or copper transceivers. – Ron Maupin Feb 26 '16 at 18:23
  • I believe you are correct, Ron. Thank you. Wishful thinking on my part hoping that link speed negotiation would work. %2SWTRUNK-I-TRNKPORTPARAM: auto-negotiation/adv. capabilities of port te0/1 differ from auto-negotiation/adv. capabilities of Po4 – Christopher Dallas Feb 26 '16 at 18:25
0

You have a speed mismatch when using fiber. You are trying to connect 1 Gb to 10 Gb and that won't work.

You can get the C3KX-NM-10G for your Cisco 3560. It can have either four 1 Gb SFPs (copper or fiber), or two 10 Gb SFPs. This will allow you to connect the Cisco and Dell in the way you are attempting.

FYI:

Be aware the the Cisco will default to use PVST for STP. I don't know if the Dell can do that, but you should probably change that on the Cisco before connecting to non-Cisco equipment.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.