2

enter image description here

This is a lab setup. Fundamentally, I'm dealing with two switches and a router. From the bottom to the top of the topology:

I have a trunk coming into a switch. This trunk carries traffic from multiple VMs, each assigned a VLAN. From this switch, I separate the incoming vlans through access ports to yet another switch. At this switch, there's a trunk heading to a router.

If I try to ping from VM to router, I only have connectivity through a single VLAN. If I disable interfaces, networking works for each VLAN separately.

Does this suggest some sort of loop?

My target is to guarantee that traffic is flowing only through certain access ports between the switches. By the way, if I trunk everything across the topology, everything works fine.

(edit to include image)

ok heres my config file... I was able to successfull ping between two switches using only access port on totally different vlans (vlan 10 and vlan 20)

Sorry about the wrapped text... dont know how to make it show line by line on this site.

Switch1

Switch#show running-config 
Building configuration...

Current configuration : 1847 bytes 
! 
version 12.2 
no service timestamps log datetime msec 
no service timestamps debug datetime msec 
no service password-encryption 
! 
hostname Switch 
! 
! 
! 
! 
! 
spanning-tree mode pvst 
! 
interface FastEthernet0/1
 switchport access vlan 10 
 switchport mode access 
! 
interface FastEthernet0/2
 switchport access vlan 10 
! 
interface FastEthernet0/3 
 switchport access vlan 10 
! 
interface FastEthernet0/4
 switchport access vlan 10 
! 
interface FastEthernet0/5 
 switchport access vlan 10 
! 
interface FastEthernet0/6
 switchport access vlan 10 
! 
interface FastEthernet0/7
 switchport access vlan 10 
! 
interface FastEthernet0/8
 switchport access vlan 10 
! 
interface FastEthernet0/9
 switchport access vlan 10 
! 
interface FastEthernet0/10
 switchport access vlan 10 
! 
interface FastEthernet0/11
 switchport access vlan 20 
 switchport mode access 
! 
interface FastEthernet0/12
 switchport access vlan 20 
 switchport mode access 
! 
interface FastEthernet0/13 
 switchport access vlan 20 
 switchport mode access 
! 
interface FastEthernet0/14
 switchport access vlan 20
 switchport mode access 
! 
interface FastEthernet0/15
 switchport access vlan 20 
 switchport mode access 
! 
interface FastEthernet0/16
 switchport access vlan 20 
 switchport mode access 
! 
interface FastEthernet0/17
 switchport access vlan 20
 switchport mode access 
! 
interface FastEthernet0/18
 switchport access vlan 20 
 switchport mode access 
! 
interface FastEthernet0/19
 switchport access vlan 20 
 switchport mode access 
! 
interface FastEthernet0/20
 switchport access vlan 20 
 switchport mode access 
! 
interface FastEthernet0/21 
! 
interface FastEthernet0/22 
! 
interface FastEthernet0/23 
! 
interface FastEthernet0/24 
! 
interface GigabitEthernet0/1 
! 
interface GigabitEthernet0/2 
! 
interface Vlan1
 no ip address
 shutdown 
! 
! 
! 
! 
line con 0 
! 
line vty 0 4 
 login 
line vty 5 15 
 login 
! 
! 
end

Switch#

heres Switch 2

Switch#show running-config 
Building configuration...

Current configuration : 2097 bytes 
! 
version 12.2 
no service timestamps log datetime msec 
no service timestamps debug datetime msec 
no service password-encryption 
! 
hostname Switch 
! 
! 
! 
! 
! 
spanning-tree mode pvst 
! 
interface FastEthernet0/1
 switchport access vlan 10 
 switchport mode access 
! 
interface FastEthernet0/2
 switchport access vlan 10 
 switchport mode access 
! 
interface FastEthernet0/3
 switchport access vlan 10 
 switchport mode access 
! 
interface FastEthernet0/4
 switchport access vlan 10 
 switchport mode access 
! 
interface FastEthernet0/5
 switchport access vlan 10 
 switchport mode access 
! 
interface FastEthernet0/6
 switchport access vlan 10 
 switchport mode access 
! 
interface FastEthernet0/7
 switchport access vlan 10 
 switchport mode access 
! 
interface FastEthernet0/8
 switchport access vlan 10 
 switchport mode access 
! 
interface FastEthernet0/9
 switchport access vlan 10 
 switchport mode access 
! 
interface FastEthernet0/10
 switchport access vlan 10 
 switchport mode access 
! 
interface FastEthernet0/11
 switchport access vlan 20 
 switchport mode access 
! 
interface FastEthernet0/12
 switchport access vlan 20 
 switchport mode access 
! 
interface FastEthernet0/13
 switchport access vlan 20 
 switchport mode access 
! 
interface FastEthernet0/14
 switchport access vlan 20 
 switchport mode access 
! 
interface FastEthernet0/15
 switchport access vlan 20 
 switchport mode access 
! 
interface FastEthernet0/16
 switchport access vlan 20 
 switchport mode access 
! 
interface FastEthernet0/17
 switchport access vlan 20 
 switchport mode access 
! 
interface FastEthernet0/18
 switchport access vlan 20 
 switchport mode access 
! 
interface FastEthernet0/19
 switchport access vlan 20 
 switchport mode access 
! 
interface FastEthernet0/20
 switchport access vlan 20 
 switchport mode access 
! 
interface FastEthernet0/21 
! 
interface FastEthernet0/22 
! 
interface FastEthernet0/23 
! 
interface FastEthernet0/24 
! 
interface GigabitEthernet0/1 
! 
interface GigabitEthernet0/2 
! 
interface Vlan1
 no ip address shutdown 
! 
interface Vlan10
 no ip address 
! 
! 
! 
! 
line con 0 
! 
line vty 0 4
 login 
line vty 5 15
 login 
! 
! 
end

Switch#
7
  • You need to provide a lot more information. What are the device models and configurations. A drawing which shows the connections and which ports are used would be nice, too.
    – Ron Maupin
    Feb 26, 2016 at 21:22
  • You might find this question and comments enlightening: networkengineering.stackexchange.com/questions/12712/…
    – Ecnerwal
    Feb 27, 2016 at 12:43
  • 1
    You should include the switch configurations. Also, I'm confused about the VMs. Where and how are they connected? Whichever VLAN a host is connected to is the only VLAN through which it can connect.
    – Ron Maupin
    Mar 3, 2016 at 20:44
  • Ron, sorry for the confusion. Peter Green answered the original question. I added the picture in response to Baker's answer. I'll provide switch configs and a full network diagram at some stage. Thanks!
    – The_Glidd
    Mar 3, 2016 at 20:51
  • @ The_Glidd ok heres my config file... I was able to successfully ping between two switches using only access port on totally different vlans (vlan 10 and vlan 20) Switch1 Switch#show running-config Building configuration... Current configuration : 1847 bytes ! version 12.2 no service timestamps log datetime msec no service timestamps debug datetime msec no service password-encryption ! hostname Switch ! ! ! ! ! spanning-tree mode pvst ! interface FastEthernet0/1 switchport access vlan 10 switchport mode access ! interface FastEthernet0/2 switchport access vlan 10 ! interface FastEthernet0/3 s
    – Baker
    Mar 3, 2016 at 22:15

3 Answers 3

0

The issue is that many forms of spanning tree protocol work on the whole port, not on individual VLANS. So they think there is a loop in your setup and start blocking ports despite the ports being on different vlans.

There are more advanced variants of spanning tree protocol ( MSTP, some vendor specific stuff) that you may be able to use if your hardware supports them.

Disabling spanning tree protocol completely may also be an option, obviously if you do that you have to take manual responsibity for ensuring there are no loops.

1
  • This put me on the right track. I disabled rstp on the switches (a Juniper 4300 and a Juniper 3300) and I'm home. I'm sure there's a more elegant way to do it, but for this small set-up, quick and dirty is fine.
    – The_Glidd
    Feb 29, 2016 at 17:11
1

It depends of the brand of the switches.

Many switches will let tagged traffic pass trough the ports configured in access mode, so creating many loops that may be cut by spanning tree.

Check the spanning tree status of each ports ("forwarding" or "blocking") on both switches and you will have your answer.

0

This is an older question but I'm curious as to how you're able to send multiple VLAN packets over an access port to another switch. Your statement...

"I separate the incoming VLANs through access ports to yet another switch. At this switch..."

To send multiple VLANs to another switch, both ports on the switches should be configured as trunk ports, and the port going to the router should also be configured as a trunk.

Only frames that belong to the native VLAN will be untagged and can be seen to native assigned ports.

1
  • I added a picture to hopefully clarify. VLAN11 and VLAN12 are trunked into SW2. Then they take separate paths to SW1. Apologies for MS Paint skills.
    – The_Glidd
    Mar 3, 2016 at 20:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.