1

I am currently having trouble gaining internet access from the PC. Any suggestions or advice would be most welcome :)

enter image description here

In order to diagnose a much larger issue, I have scaled my lab configuration down to just the basics. - pfsense firewall - 1 x router: e0: 192.168.10.10, e1: 192.168.20.1 - 1 x PC: static IP address (attached to the Router)

I am able to Ping, traceroute, and telnet to the outside (74.125.224.72 (aka Google)) from the PC, but when I open a web browser, the system just times out.

Router config:

interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 ip address 192.168.10.10 255.255.255.0
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 192.168.20.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!         
ip nat inside source list 1 interface GigabitEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0 192.168.10.1
!
access-list 1 permit 192.168.20.0 0.0.0.255 
  • PCAP from firewall of PC-Telnet to: 74.125.224.72

18:50:04.436603 IP 192.168.10.10.49400 > lax17s02-in-f8.1e100.net.http: tcp 0
18:50:04.475986 IP lax17s02-in-f8.1e100.net.http > 192.168.10.10.49400: tcp 0
18:50:04.476401 IP 192.168.10.10.49400 > lax17s02-in-f8.1e100.net.http: tcp 0
18:50:05.375308 
18:50:15.375257 
18:50:25.375135 
18:50:33.093910 IP 192.168.10.10.49400 > lax17s02-in-f8.1e100.net.http: tcp 2
18:50:33.133231 IP lax17s02-in-f8.1e100.net.http > 192.168.10.10.49400: tcp 0
18:50:35.451082 
18:50:35.714407 IP 192.168.10.10.49400 > lax17s02-in-f8.1e100.net.http: tcp 5
18:50:35.753729 IP lax17s02-in-f8.1e100.net.http > 192.168.10.10.49400: tcp 0
18:50:38.442287 IP 192.168.10.10.49400 > lax17s02-in-f8.1e100.net.http: tcp 5
18:50:38.481624 IP lax17s02-in-f8.1e100.net.http > 192.168.10.10.49400: tcp 0
18:50:40.034061 IP 192.168.10.10.49400 > lax17s02-in-f8.1e100.net.http: tcp 3
18:50:40.073419 IP lax17s02-in-f8.1e100.net.http > 192.168.10.10.49400: tcp 0
18:50:40.073669 IP lax17s02-in-f8.1e100.net.http > 192.168.10.10.49400: tcp 1418
18:50:40.073750 IP lax17s02-in-f8.1e100.net.http > 192.168.10.10.49400: tcp 264
18:50:40.073757 IP lax17s02-in-f8.1e100.net.http > 192.168.10.10.49400: tcp 0
18:50:40.074082 IP 192.168.10.10.49400 > lax17s02-in-f8.1e100.net.http: tcp 0
18:50:40.074165 IP 192.168.10.10.49400 > lax17s02-in-f8.1e100.net.http: tcp 0
18:50:40.074174 IP 192.168.10.10.49400 > lax17s02-in-f8.1e100.net.http: tcp 0
18:50:40.113467 IP lax17s02-in-f8.1e100.net.http > 192.168.10.10.49400: tcp 0
18:50:42.995028 CDPv2, ttl: 180s, Device-ID 'Router', length 349

  • Wireshark pcap

enter image description here

Thank you all again for your time,

2
  • Are you browsing to the IP or the host name? If host name, have you confirmed dns is resolving correctly for you? – dareuja Feb 27 '16 at 1:13
  • 1
    It depends on how you are assigning your IP addresses to your hosts. If you are manually assigning them, you need to assign DNS servers to them, too. You can assign local DNS server(s), ISP DNS server(s), or public (such as Google) DNS servers. If you are using DHCP to assign them, you need to make sure your DHCP server is assigning valid DNS servers, otherwise, you may need to manually assign them. Beyond than that, end-device (PCs and servers) configurations are off topic here, but you can ask those sorts of questions on Super User. – Ron Maupin Feb 27 '16 at 2:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.