2

I have a gateway rv320 cisco(lets name it BR) and inter router Cisco 1921 (lets name it RTR)

i was having trouble pinging the lan port on the BR from my hosts, but someone helped me fix that issue.

However, my hosts cannot ping the internet (google.com).
My RTR can ping the INTERNET.

for some reason it gets dropped at the PC's default gateway. Tracert only goes up to the default gateway (172.16.10.1) and does not seem to go past that.

Here is my config from my RTR

    service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname T-RTR
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$g2ly$xT6VHT1gXBTLuXp6uJlp./
!
no aaa new-model
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
cts logging verbose
!
!
license udi pid CISCO1921/K9 sn FGL1943200R
!
!
!
redundancy
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 ip address dhcp
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/1.10
 encapsulation dot1Q 10
 ip address 172.16.10.1 255.255.255.0
!
interface GigabitEthernet0/1.20
 encapsulation dot1Q 20
 ip address 172.16.20.1 255.255.255.0
!
interface GigabitEthernet0/1.30
 encapsulation dot1Q 30
 ip address 172.16.30.1 255.255.255.0
!
router rip
 version 2
 passive-interface GigabitEthernet0/1
 network 172.16.0.0
 network 192.168.1.0
 no auto-summary
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
banner motd ^C Unauthorized Access is prohibited!^C
!
line con 0
 password Group1
 login
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 login
 transport input none
!
scheduler allocate 20000 1000
!
end

My routing table:

Gateway of last resort is 192.168.1.1 to network 0.0.0.0

S*    0.0.0.0/0 [254/0] via 192.168.1.1
      172.16.0.0/16 is variably subnetted, 6 subnets, 2 masks
C        172.16.10.0/24 is directly connected, GigabitEthernet0/1.10
L        172.16.10.1/32 is directly connected, GigabitEthernet0/1.10
C        172.16.20.0/24 is directly connected, GigabitEthernet0/1.20
L        172.16.20.1/32 is directly connected, GigabitEthernet0/1.20
C        172.16.30.0/24 is directly connected, GigabitEthernet0/1.30
L        172.16.30.1/32 is directly connected, GigabitEthernet0/1.30
      172.17.0.0/24 is subnetted, 3 subnets
R        172.17.10.0 [120/1] via 192.168.1.3, 00:00:18, GigabitEthernet0/0
R        172.17.20.0 [120/1] via 192.168.1.3, 00:00:18, GigabitEthernet0/0
R        172.17.30.0 [120/1] via 192.168.1.3, 00:00:18, GigabitEthernet0/0
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, GigabitEthernet0/0
L        192.168.1.2/32 is directly connected, GigabitEthernet0/0
R     192.168.13.0/24 [120/1] via 192.168.1.1, 00:00:15, GigabitEthernet0/0

enter image description here

4
  • I think the first configuration you give is for RTR, not BR, as you indicate. You didn't include the DHCP-assigned address of RTR (you really shouldn't use DHCP to assign addresses to routing infrastructure devices), but from the routing table, it looks like 192.168.1.3. – Ron Maupin Feb 27 '16 at 19:02
  • Yea i know i should not be using dhcp, but im using it because of other issues im having.. but i will change it as soon as im done with this issue. You are right, it was a typo, i corrected the typo. I got two RTRs one for 172.16.x.x and one for 172.17.x.x network. both are having the same issue, but if i fix one side, i should be able to apply the same fix to the other side. RTR (192.168.1.2) <--->BR – nando Feb 28 '16 at 2:12
  • I think the fix is in the BR. Read my answer. Your hop count for the default route is beyond what RIP allows. – Ron Maupin Feb 28 '16 at 2:13
  • Did any answer help you? if so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer. – Ron Maupin Aug 7 '17 at 20:07
1

Well, my problem is solved. It looks like RIPv2 was working fine on both BR and RTR. I went to Firewall > Block WAN requests [x] (in my br) and unchecked it. It was checked by default. I also went to ACL and allowed any traffic from any lan and now i can go out the internet with my clients and servers.. I will be modifying the ACL to secure my network once im done with the rest of the project. THANKS TO EVERYONE! for helping!

0

It looks like your problem could be that the path to the 192.168.13.0 network is 40 hops (per the routing table of BR), and that far exceeds the RIP maximum hop count of 15 (16 hops being infinite for RIP).

You may be able to solve this by creating a static route on BR and redistributing that into RIP with a much lower metric.

2
  • I will try that.. but if thats the case, how come RTR can ping BR WAN and even the internet? – nando Feb 28 '16 at 2:15
  • Try putting a default route in to the RTR to see if that works for the LANs connected to it. ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0 – Ron Maupin Feb 28 '16 at 2:17
0

Try #ping 192.168.13.81 source 172.16.10.1 on RTR, you can confirm RTR is working fine if this doesn't get reply.

Next, change RV320 mode to "router mode" instead of "gateway mode", it might works ok. It will break the internet connection, but it might be just how rv320 router works if that works fine(you cannot ping rv320 wan interface with gateway mode).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.