2

In the manual it says I have to create a 128x48 bmp image with 1-bit per pixel, but when i upload it to the phone, it merely displays a full black image.

I've tried:

  • creating the image with gimp, saving it as a 1-bit indexed bmp.
  • convert input.bmp -colors 2 -type Bilevel -depth 1 output.bmp

the latter produces the following output when calling identify output.bmp: output.bmp BMP 128x48 128x48+0+0 1-bit sRGB 2c 914B 0.000u 0:00.000

Which looks completely up to specs to me.

Can someone tell what i'm doing wrong, or give me pointers to debug the problem.

1

I had the same problem, and then I took a look at the example image they provided in their guide (here: https://supportforums.cisco.com/document/51231/configuring-bmp-logo-spa303-and-spa50xg-ip-phones) by using identify. Turns out their bmp is BMP version 3.

So I re-encoded my image from a monochrome png using : "convert test.png -depth 1 -type Bilevel BMP3:test.bmp" and IT WORKED HALLELUJAH!

So I feel like the 5 hours I wasted on that are completely justified. Peace out.

2
  • You sir, are my hero! -depth 1 doesn't work for me, though. The image remains 8-bit, i'll probably give this another go next friday! – Bas H Apr 18 '16 at 10:00
  • for me it was: convert test.png -depth 1 -monochrome -colors 2 -type Bilevel BMP3:test.bmp – Bas H Apr 18 '16 at 10:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.