Let's say I have two connected switches. I specifically configure (force) one of them to use full duplex and the other one I configure to use autonegotiation. Why does this config fail and the autoneg. function just can't adjust to the other port's full duplex?

2 Answers 2


When you specifically set the speed and duplex on one side of a link, that side will not negotiate, so there is no negotiation which takes place. The other side can detect, not negotiate, the link speed and adjust to it, but because there is no negotiation, it sets the default duplex, based on the speed. The default duplex for 10BASE-T and 100BASE-TX is Half Duplex. The default duplex for 1000BASE-T is Full Duplex, and 10GBASE-T only has Full Duplex.

Cisco has a document with a table which shows what happens when different speed/duplex setting are configured on each end of a link: Troubleshooting Cisco Catalyst Switches to NIC Compatibility Issues

Why Is It That the Speed and Duplex Cannot Be Hardcoded on Only One Link Partner?

As indicated in Table 1, a manual setup of the speed and duplex for full-duplex on one link partner results in a duplex mismatch. This happens when you disable autonegotiation on one link partner while the other link partner defaults to a half-duplex configuration. A duplex mismatch results in slow performance, intermittent connectivity, data link errors, and other issues. If the intent is not to use autonegotiation, both link partners must be manually configured for speed and duplex for full-duplex settings.


In addition to Ron answer, Auto-MDIX does not negotiate speed and duplex, it auto-configures which pairs in the cable are used for Transmit and Receive.

But on some switches auto-mdix is disabled if you manually set speed and duplex, which could lead to some confusion.

  • Oh yeah, did not mean to say Auto-MDIX but Autonegotiation, my mistake :)
    – PesaThe
    Commented Mar 16, 2016 at 22:34
  • And by the way, why is it that on some switches it's disabled if I manually set speed and duplex?
    – PesaThe
    Commented Mar 16, 2016 at 22:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.