6

Is it possible for a specific interface to only allow access to specific dhcp pools? This is assuming a cisco router(IOS) with dhcp server capabilities.

E.g. For some router, hosts on fa0/0 can obtain an address from pool1 (192.168.0.0/29) via dhcp, hosts on interface fa0/1 can obtain an address from pool2 (172.16.0.0/29) via dhcp.

1
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can post and accept your own answer.
    – Ron Maupin
    Jan 4, 2021 at 22:38

1 Answer 1

9

If you configure an IP address on an interface the router will use the corresponding DHCP pool to answer DHCP requests. In your case you would do something like this:

interface Fa0/0
 ip address 192.168.0.1 255.255.255.248
!
interface Fa0/1
 ip address 172.16.0.1 255.255.255.248
!
ip dhcp pool 0
 network 192.168.0.0 255.255.255.248
 ...
!
ip dhcp pool 1
 network 172.16.0.0 255.255.255.248
 ...
!

The interface IP on Fa0/0 is inside the network for DHCP pool 0 and the IP on Fa0/1 is inside pool 1. So hosts on Fa0/0 will get addresses from pool 0 and hosts on Fa0/1 will get addresses from pool 1.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.