1

I'm trying to simulate a Site-to-Site VPN.

This is what my network looks like:

enter image description here

The VPN tunnel stands for connecting Technology center router to R1, the running configurations for Technology center router are these:

Current configuration : 1713 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname TCR
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2901/K9 sn FTX1524158U
license boot module c2900 technology-package securityk9
!
!
!
crypto isakmp policy 10
 encr aes
 authentication pre-share
 group 2
!
crypto isakmp key cisco address 10.2.2.2
!
!
!
crypto ipsec transform-set VPN-SET esp-3des esp-sha-hmac
!
crypto map VPN-MAP 10 ipsec-isakmp 
 description VPN connection to R1
 set peer 10.2.2.2
 set transform-set VPN-SET 
 match address 100
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 bandwidth 64000
 ip address 10.1.1.1 255.0.0.0
 clock rate 128000
 crypto map VPN-MAP
!
interface Serial0/0/1
 no ip address
 clock rate 2000000
 shutdown
!
interface FastEthernet0/1/0
 switchport mode access
!
interface FastEthernet0/1/1
 switchport mode access
 shutdown
!
interface FastEthernet0/1/2
 switchport mode access
 shutdown
!
interface FastEthernet0/1/3
 switchport mode access
 shutdown
!
interface Vlan1
 ip address 192.168.0.1 255.255.255.0
!
ip classless
!
ip flow-export version 9
!
!
access-list 100 permit ip 192.168.0.0 0.0.0.255 192.168.1.0 0.0.0.255
access-list 100 permit ip 192.168.0.0 0.0.0.255 192.168.2.0 0.0.0.255
access-list 100 permit ip 192.168.0.0 0.0.0.255 192.168.3.0 0.0.0.255
access-list 100 permit ip 192.168.0.0 0.0.0.255 192.168.4.0 0.0.0.255
!
!
!
!
!
line con 0
!
line aux 0
!
line 0/2/0 0/2/7
 login
!
line vty 0 4
 login
!
!
!
end

and the running configurations for R1:

Current configuration : 1503 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2901/K9 sn FTX1524PZ05
license boot module c2900 technology-package securityk9
!
!
!
crypto isakmp policy 10
 encr aes
 authentication pre-share
 group 2
!
crypto isakmp key cisco address 10.1.1.1
!
!
!
crypto ipsec transform-set VPN-SET esp-3des esp-sha-hmac
!
crypto map VPN-MAP 10 ipsec-isakmp 
 description VPN connection to TCR
 set peer 10.1.1.1
 set transform-set VPN-SET 
 match address 100
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 bandwidth 64000
 ip address 10.2.2.2 255.0.0.0
 clock rate 128000
 crypto map VPN-MAP
!
interface Serial0/0/1
 no ip address
 clock rate 2000000
 shutdown
!
interface FastEthernet0/1/0
 switchport mode access
!
interface FastEthernet0/1/1
 switchport mode access
 shutdown
!
interface FastEthernet0/1/2
 switchport mode access
 shutdown
!
interface FastEthernet0/1/3
 switchport mode access
 shutdown
!
interface Vlan1
 ip address 192.168.1.1 255.255.255.0
!
ip classless
!
ip flow-export version 9
!
!
access-list 100 permit ip 192.168.1.0 0.0.0.255 192.168.0.0 0.0.0.255
!
!
!
!
!
line con 0
!
line aux 0
!
line 0/2/0 0/2/7
 login
!
line vty 0 4
 login
!
!
!
end

Why R1 and Technology center router can't ping on each other ?

2
  • 1
    First, can R1 ping the TCR without the tunnel? What is the output of "show crypto ipsec sa"? Look in your log messages for problems. – Ron Trunk Mar 19 '16 at 13:10
  • now I found a solution that I sat-up the LANs to bing the TCR without tunnel as u said, then i made the VPN tunnel and it works, but after I made the VPN tunnel other LANs can't ping on TCR. any idea why is that ? and how to make a seprate tunnel for each LAN to TCR ? – Poula Adel Mar 21 '16 at 16:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.