3

My Plan (Short Version)

Actually we have three access points directly connected to our router. I want all of them to connect to a switch and from there only one cable to the router.

The Hardware:

  • Router: Cisco 1812
  • Switch: Dell Powerconnect 5324
  • Access Points: Cisco Aironet AIR-SAP702I-E-K9 (3 Pieces)

My Plan (Longer Version):

Actually, we have a Cisco router 1812 with three access points directly connected to it. Everything works fine, but I think it is waste of ports. Also, I need a free port next week because of new hardware. The access points have two SSIDs (Private, Guest), with VLAN40 (Private) and VLAN50 (Guest) on it. What I want is that one port on the router be a trunk Port which carries both VLANs, and I want to use four Ports on the DELL PowerConnect 5324. One for the link to the router, and three for the access points.

Questions:

  1. How should I configure the ports on the switch and the port on the router? I think the router's port should be switchport mode trunk, or do I even have to change it because it is actually configured like this? (I'll post the configuration below!)
  2. How does this even work? Because the Port doesn't have VLAN50 configured. FYI: VLAN10 is DMZ-VLAN, it has nothing to do with the AP.
  3. Do I only need to add VLAN 40 & VLAN 50 to allowed VLANs on the 4 Ports?
  4. Is there a standard protocol for VLAN numbers? Because how does the Switch know, which AP has VLAN40 if it is only configured on the router? Can those two different pieces of hardware communicate well, even if they are from two different companies?

Configuration:

ROUTER:

interface FastEthernet6
 description AccesPoint1
 switchport access vlan 10
 switchport trunk native vlan 40
 switchport mode trunk
!         
interface FastEthernet7
 description AccessPoint2
 switchport access vlan 10
 switchport trunk native vlan 40
 switchport mode trunk
!         
interface FastEthernet8
 description AccessPoint3
 switchport access vlan10 
 switchport trunk native vlan 40
 switchport mode trunk

ACCESS POINTS:

interface GigabitEthernet0
 no ip address
 no ip route-cache
 duplex auto
 speed auto
 hold-queue 160 in
!         
interface GigabitEthernet0.1
 encapsulation dot1Q 1
 no ip route-cache
!         
interface GigabitEthernet0.40
 encapsulation dot1Q 40 native
 no ip route-cache
 bridge-group 1
 bridge-group 1 spanning-disabled
 no bridge-group 1 source-learning
!         
interface GigabitEthernet0.50
 encapsulation dot1Q 50
 no ip route-cache
 bridge-group 50
 bridge-group 50 spanning-disabled
 no bridge-group 50 source-learning
!         

I think I don't need to post the VLAN Configuration itself, ACLs, or something else because it shouldn't be changed; only the interfaces need to be configured another Way.

The switch isn't configured yet because I hope there will be some nice input and help here.

1
  1. On the switch, the four ports should all be the same:
    • Make VLAN 40 untagged.
    • Make VLAN 50 tagged.

You don't have to make any changes to the router. You can use any port you've shown us, as they are all configured the same.

  1. By default, Cisco will allow all VLANs on a trunk port. You don't have to explicitly allow VLAN 50, although it's generally a good idea to only allow the ones you need.

  2. If you want to specify which VLANs, then yes.

  3. There's no standard for VLAN numbers. The VLAN information (VID) is carried in the 802.1q Ethernet frame.

  • Thanks! I will try this tommorow. I'll show my result. Would be nice to hear of you again. So because of the 802.1q Frame, every hardware client know that VLAN40 is VLAN40 and don't have another number. Nice to know. Thank you! – SystemCookie Mar 21 '16 at 21:01
  • Actually, VLAN 40 is the untagged or native VLAN, so it doesn't have a tag. But VAN 50 does. – Ron Trunk Mar 21 '16 at 21:37
  • Hi, it worked like you said. I also added VLAN40 as PVID (Native) on the Switch. – SystemCookie Mar 31 '16 at 9:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.