0

I tried connecting to the switch console. But I always get black screen and can't type anything. I changed the speed to different values ( | 1200 | 2400 | 4800 | 9600 | 19200 |38400 | 57600), I still get the same black screen.

7
  • Can you connect to another serial device with the same machine & cable? Did you set the flow control to "none"?
    – JFL
    Apr 1 '16 at 13:10
  • yes I can connect to the d-Link switch and the HP v1910-24G switch with the same cable and machine. and yes the flow control is set to none.
    – sirine.ch
    Apr 1 '16 at 13:13
  • It seems that actually the flow control should be set to XON-XOFF, cf this doc section 5-16 (page 100). Did you try it?
    – JFL
    Apr 1 '16 at 13:49
  • I tried it and I also reset it as some have suggested that but still the same thing keeps happening.
    – sirine.ch
    Apr 2 '16 at 11:47
  • @sirine.ch I know it sounds silly... But have you mashed enter several times? Also, if you plug the serial cable in and reboot the switch do you see any output whilst the switch boots? If not I'd be looking at talking to HP about a replacement. I think the 2500 series comes with limited lifetime warranties.
    – Mark
    Aug 5 '16 at 12:26
2

Probably the baud rate is fixed to something you didn't try. If you can run a telnet or ssh session, you can check the serial console setting with show console.

You can reset to default settings by

console baud-rate speed-sense
console flow-control xon/xoff
console local-terminal vt100
2

HP Procurves should auto-sense any reasonable speed, but 8-N-1-XOn/XOff are required.

1

you may have to try 115200 as well, as it comes as default speed on some models.

0

Since I couldn't connect using the console cable directly, I installed a dhcp server temporarily, then I accesses the leased ip address to my HP Procurve switch, changed the IP into a static one and accessed the switch terminal through a telnet connection. afterward I stopped the dhcp server since I don't really need it any more.

2
  • 1
    You answered your own question, which is encouraged here. However, it's not an answer to the question you posted, you told us how you worked around the problem.
    – Teun Vink
    Apr 7 '16 at 9:30
  • It's true, I guess I'll remove it and hopefully someone will answer it directly.
    – sirine.ch
    Apr 7 '16 at 12:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.