6

I am trying to configure inter-VLAN routing, but I can't route using MLS. I attached the image. Please check and give the answers.

In switch0 I created VLANs 2 and 4; in switch1 only VLAN 3; in switch2 VLANs 5 and 6. I want to communicate between all the VLANs. Please tell me the configuration in L3 switch. I have not configured that because of lack of knowledge.

Please refer to the image and give me reply, thanks.

These are the IP addresses which I gave to the corresponding VLANs:

  • VLAN 2 IP = 192.168.11.0
  • VLAN 3 IP = 192.168.12.0
  • VLAN 4 IP = 192.168.13.0
  • VLAN 5 IP = 192.168.14.0
  • VLAN 6 IP = 192.168.15.0 enter image description here

The layer-3 switch configuration:

ip routing 
! 
spanning-tree mode pvst 
! 
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk 
! 
interface FastEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk 
! 
interface FastEthernet0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk 
! 
! 
interface Vlan1
 no ip address
 shutdown 
interface Vlan2
 ip address 192.168.11.100 255.255.255.0
interface Vlan4
 ip address 192.168.13.100 255.255.255.0 
interface Vlan5
 ip address 192.168.14.100 255.255.255.0 
interface Vlan6
 ip address 192.168.15.100 255.255.255.0 
ip classless

Switch 0 configuration:

SW0#sh run
Building configuration...

Current configuration : 1163 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SW0
!
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 switchport access vlan 2
 switchport mode access
!
interface FastEthernet0/2
 switchport access vlan 4
 switchport mode access
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
 switchport mode trunk
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end              

Switch 1 configuration:

SW1>
SW1>en
SW1#sh run
Building configuration...

Current configuration : 1290 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SW1
!
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 switchport access vlan 3
 switchport mode access
!
interface FastEthernet0/2
 switchport access vlan 3
 switchport mode access
!
interface FastEthernet0/3
 switchport access vlan 3
 switchport mode access
!
interface FastEthernet0/4
 switchport access vlan 3
 switchport mode access
!
interface FastEthernet0/5
 switchport access vlan 3
 switchport mode access
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end

Switch 2 configuration:

SW2#sh run
Building configuration...

Current configuration : 1140 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SW2
!
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 switchport access vlan 5
 switchport mode access
!
interface FastEthernet0/2
 switchport access vlan 6
 switchport mode access
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end
  • did you set an IP on each vlan interface on the L3 switch and enable routing on it? Please provide complete switch brand/model/software version and configuration. – JFL Apr 3 '16 at 7:40
  • What kind of switches do you use? Model? So, If you use HP switches, please typing ip routing It will enable routing on your L3 switch. – Julien Apr 3 '16 at 7:46
  • am doing in packetracer.am not getting ping from l3 to l2 switches also.i configure fa0/24 as trunk.but still am not getting.please help – Robichayanzz Apr 3 '16 at 8:04
  • in l2 switches I create vlans and their ports. And created one port as trunk and in l3 switches I done vlan with ip and each port to switch as trunk. I done all these in packet racer. – Robichayanzz Apr 3 '16 at 8:15
  • Edit your question to include your configuration, otherwise we are guessing where you went wrong. – Ron Maupin Apr 3 '16 at 15:10
2

Configure each VLAN with "no shutdown." Make sure that the VLANs are active. "Conf t" and the type "vlan 2" and see if that brings the VLAN up. Do this with the rest of the VLANs.

Make sure that each switch has all VLANs configured, or else you won't be able to trunk those VLANs.

This should solve your problem...

1

You still need to configure the VLAN 3 SVI on the L3 switch.

You also need to set trunk mode and encapsulation on Fa0/24 of all three L2 switches.

0

You have the same configuration for all the switches. Based on your question and diagrams, I think you need to change the layer-2 access switches' configurations to something like this (for the leftmost layer-2 switch in the bottom diagram):

version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname L2SWITCH0
!
no ip routing
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 no switchport trunk encapsulation dot1q
 no switchport mode trunk
 switchport access VLAN 2
 switchport mode access
!
interface FastEthernet0/2
 no switchport trunk encapsulation dot1q
 no switchport mode trunk
!
interface FastEthernet0/3
 no switchport trunk encapsulation dot1q
 no switchport mode trunk
!
interface FastEthernet0/4
 no switchport trunk encapsulation dot1q
 no switchport mode trunk
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
 switchport access VLAN 4
 switchport mode access
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan2
 no ip address 192.168.11.100 255.255.255.0
!
interface Vlan3
 no ip address 192.168.12.100 255.255.255.0
!
interface Vlan4
 no ip address 192.168.13.100 255.255.255.0
!
interface Vlan5
 no ip address 192.168.14.100 255.255.255.0
!
interface Vlan6
 no ip address 192.168.15.100 255.255.255.0
!
ip classless
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
end
0

Each IDF switch needs to have it's FastEthernet from the year 1999 set to 802.1q trunking and trunking mode (to math the other end on the core L3 switch). Each IDF home-runs to the core layer3 switch so don't enable any additional STP. If something is default probably leave it but otherwise take all the STP off. Each switch needs to see all VLANs via either manual configuration of the VLAN database or VTP.

You also need to assign each IDF switch with an IP address on int VLAN1 for management purposes and configure telnet or SSH access is possible.

0

Configure default gateway on the device (ex. PC) connected to the switch. On the switch it would be:

ip default-gateway 192.168.11.100

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.