0

In the HP Procurve manual it says to use the following command to up load a file from the switch to a tftp server:

HP2512# copy startup-config tftp 13.28.227.105 d:\configs\sw2512

In my case, my tftp server is on a ubuntu 14.04 LTS machine, so I did the following:

HP2512# copy startup-config tftp myIP /tftpboot/swconf

But it didn't work :

Transport Error.

5
  • 1
    an absolute path behind the tftp server seems weird. The path should be relative to the tftp server base folder, not to the OS file system. Can you try just with a filename, like "copy startup-config tftp myip swconf"? Also are you sure you run a tftp server and not a ftp server? Those are different things. – JFL Apr 7 '16 at 12:33
  • I tried the absolute path and still get the same error – sirine.ch Apr 7 '16 at 12:55
  • What do the logs on the server say? – Teun Vink Apr 7 '16 at 19:18
  • Did any answer help you? if so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer. – Ron Maupin Aug 7 '17 at 21:22
2

It's most likely a tftpd configuration problem: it is rather picky. Check you are running as a user with write permissions, that SELinux isn't preventing writes; read very carefully the man page, especially the bits about --create and --permissive. If that doesn't get you anywhere, crank up the verbosity and check the syslogs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.