I inherited a small setup for a VM complex. It is centrally connected via a Juniper EX Switch Stack (as a virtual chassis). Connected to it via lag/trunks (carrying all the same vlans) are 4 Dell blade chassis with integrated switches (6348). The Juniper has RSTP enabled however nothing specific configured.

The Dell chassis switches do not have spanning-tree enabled, and chassis3 (which is an older chassis than the 6348) is being elected root bridge currently.

Is there any good reason spanning-tree would be disabled in this setup or was this just a bad setup from the beginning?

Juniper-Dell complex

  • I can't think of any reason other then if they had VLAN's and there was some sort of complication, they could have configured MST
    – Chris Zog
    Commented Apr 7, 2016 at 18:20
  • Did any answer help you? if so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer.
    – Ron Maupin
    Commented Aug 7, 2017 at 17:37

3 Answers 3


I wouldn't disable STP in your topology. There's no need to. STP is used to ensure a loop free topology. If they haven't been already, you should bundle your Dell ports into a single port channel. As your EXs are stacked they appear as one logical switch and therefore will be able to form port channels on their end too. This results in you having a logical star topology with no loop, therefore STP will not block any ports.

If you're concerned about Chassis 3 being the root bridge you should reduce EX stack's priority to ensure that it becomes the root bridge. FYI though, if you implement port channels as I've suggested above there are no redundant paths for STP to block, therefore it doesn't matter which switch is the root bridge. (To cover off future issues though you should make your core switch the root bridge as suggested above).

STP should never be disbaled unless you have an extremely good reason to do so. If you're wanting to reduce the amount of time it takes for an access port to come up, you should configure it as an edge port instead of disabling STP.


Without much information to examine your setup, it sounds like a bad implementation of 802.1w. You'd want root 802.1d/w/s on your distribution switch (perhaps your juniper stack) and not your core or access switches.

Spanning tree will protect your infrastructure from layer2 misconfigs but it has been known to have taken down the core/distribution/access switches due to some unexpected mishaps. Any connection from your distribution to your core switch could be a point-to-point layer 3, using a /30 if you like and run some l3 protocol like ospf if you have one or many distribution switches to your cores.

If link-up speed and/or vendor protocol compatibility are issues, you could create L3 ospf point-to-point between your distribution to your access switches (dell 6348) and leave the access as spanning tree root. That may require some good planning and some capacity for expansion if you implement more servers later on.


In STP when a new link on a port comes up it takes almost a minute for STP to listen on that port and make sure there isn't a loop back to itself before allowing frames to pass. Some services like DHCP will timeout during this wait.

The only reason I know of to turn off STP is on access ports for hosts so they come up immediately. With that said its best practice to enable BPDU guard or filter to immediately shut that port down if a loop does occur.

In your setup, the Juniper stack w/ RSTP provides protection from loops. If there is any way a loop could be created on the Dell switches I would enable STP everywhere, otherwise I would leave it be.

  • The Dell switches also support RSTP, which I planned on enabling, because it seems like it's at least insurance just in case. But I was just making sure there wasn't some wacky reasoning I missed. Thanks!
    – Ippy
    Commented Apr 7, 2016 at 19:48
  • 1
    You should not disable STP on access ports to reduce the amount of time it takes to bring the port up. You should instead configure these ports as "edge" ports - juniper.net/techpubs/software/junos/junos95/swconfig-layer-2/…
    – OzNetNerd
    Commented May 11, 2016 at 6:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.