1

enter image description here In server: C3650-48TS, 03.03.05SE

SW01#sh vtp sta
VTP Version capable             : 1 to 3
VTP version running             : 1
VTP Domain Name                 : TEST
VTP Pruning Mode                : Disabled
VTP Traps Generation            : Disabled
Device ID                       : aaaa.aaaa.aaaa
Configuration last modified by xxx.xxx.xxx.xxx at 4-23-16 04:41:17
Local updater ID is xxx.xxx.xxx.xxx on interface Vl1 (lowest numbered VLAN interface found)

Feature VLAN:
--------------
VTP Operating Mode                : Server
Maximum VLANs supported locally   : 1005
Number of existing VLANs          : 15
Configuration Revision            : 7
MD5 digest                        : 0xC1 0x5A 0x47 0xDB 0x1A 0x6E 0x8E 0x3E
                                0xF4 0xF2 0xE3 0x52 0x4B 0x44 0x85 0xB2

working client: C2960X, 15.0(2a)EX5

SW02#sh vtp sta
VTP Version capable             : 1 to 3
VTP version running             : 1
VTP Domain Name                 : TEST
VTP Pruning Mode                : Disabled
VTP Traps Generation            : Disabled
Device ID                       : bbbb.bbbb.bbbb
Configuration last modified by xxx.xxx.xxx.xxx at 4-23-16 04:41:17

Feature VLAN:
--------------
VTP Operating Mode                : Client
Maximum VLANs supported locally   : 1005
Number of existing VLANs          : 15
Configuration Revision            : 7
MD5 digest                        : 0xC1 0x5A 0x47 0xDB 0x1A 0x6E 0x8E 0x3E
                                0xF4 0xF2 0xE3 0x52 0x4B 0x44 0x85 0xB2

Client not supporting VTP: C2960X, 15.0(2)EX5

SW03#sh vtp sta
VTP Version capable             : 1 to 3
VTP version running             : 1
VTP Domain Name                 : TEST
VTP Pruning Mode                : Disabled
VTP Traps Generation            : Disabled
Device ID                       : cccc.cccc.cccc
Configuration last modified by xxx.xxx.xxx.xxx at 3-20-16 22:11:29

Feature VLAN:
--------------
VTP Operating Mode                : Client
Maximum VLANs supported locally   : 1005
Number of existing VLANs          : 12
Configuration Revision            : 0
MD5 digest                        : 0x2C 0x19 0x9F 0x80 0x3D 0x53 0xBE 0xEA
                                0x35 0x86 0x0F 0xF8 0xAB 0x59 0x79 0x4E

No MD5 checksum error

debug message is :

Apr 25 04:26:05.878: vlan manager pkt rcvd on GigabitEthernet1/0/26, length 99
Apr 25 04:26:05.878: VTP LOG RUNTIME: Summary packet received, domain = TEST, rev = 7, followers = 0, length 77, trunk Gi1/0/26
Apr 25 04:26:05.878: VTP LOG RUNTIME: Summary packet rev 7 greater than domain TEST rev 0
Apr 25 04:26:05.878: VTP LOG RUNTIME: Domain TEST currently not in updating state
Apr 25 04:26:05.878: VTP LOG RUNTIME: Summary packet with followers field zero
Apr 25 04:26:05.878: VTP LOG RUNTIME: Transmit vtp request, domain TEST, start value 0
Apr 25 04:26:06.207: vlan manager pkt rcvd on GigabitEthernet1/0/26, length 99
Apr 25 04:26:06.207: VTP LOG RUNTIME: Summary packet received, domain = TEST, rev = 7, followers = 1, length 77, trunk Gi1/0/26
Apr 25 04:26:06.207: VTP LOG RUNTIME: Summary packet rev 7 greater than domain TEST rev 0
Apr 25 04:26:06.207: VTP LOG RUNTIME: Domain TEST currently not in updating state
Apr 25 04:26:06.207: VTP LOG RUNTIME: pdu len 77, #tlvs 1
Apr 25 04:26:06.207: vlan manager pkt rcvd on GigabitEthernet1/0/26, length 382
Apr 25 04:26:06.207: VTP LOG RUNTIME: Subset packet received, domain = TEST, rev = 7, seq = 1, length = 360
Apr 25 04:26:06.207: VTP LOG RUNTIME: MD5 digest failing
calculated = 43 0B E9 E7 9D 1A 5D C0 05 94 B2 E2 C4 F2 08 F6
transmitted = C1 5A 47 DB 1A 6E 8E 3E F4 F2 E3 52 4B 44 85 B2

Other Switches under SW03 is working after i put VTP in Transparent mode only.

Transparent mode debug message:

Apr 25 04:45:54.020: vlan manager pkt rcvd on GigabitEthernet1/0/25, length 99
Apr 25 04:45:54.020: VTP LOG RUNTIME: Relaying packet received on trunk Gi1/0/25 - in TRANSPARENT MODE (nc = false)
Apr 25 04:45:54.023: vlan manager pkt rcvd on GigabitEthernet1/0/27, length 60
Apr 25 04:45:54.023: VTP LOG RUNTIME: Relaying packet received on trunk Gi1/0/27 - in TRANSPARENT MODE (nc = false)
Apr 25 04:45:54.023: vlan manager pkt rcvd on GigabitEthernet1/0/26, length 60
Apr 25 04:45:54.023: VTP LOG RUNTIME: Relaying packet received on trunk Gi1/0/26 - in TRANSPARENT MODE (nc = false)
Apr 25 04:45:54.132: vlan manager pkt rcvd on GigabitEthernet1/0/25, length 99
Apr 25 04:45:54.132: VTP LOG RUNTIME: Relaying packet received on trunk Gi1/0/25 - in TRANSPARENT MODE (nc = false)
Apr 25 04:45:54.132: vlan manager pkt rcvd on GigabitEthernet1/0/25, length 366
Apr 25 04:45:54.132: VTP LOG RUNTIME: Relaying packet received on trunk Gi1/0/25 - in TRANSPARENT MODE (nc = false)
Apr 25 04:45:54.153: vlan manager pkt rcvd on GigabitEthernet1/0/26, length 99
Apr 25 04:45:54.156: VTP LOG RUNTIME: Relaying packet received on trunk Gi1/0/26 - in TRANSPARENT MODE (nc = false)
Apr 25 04:45:54.156: vlan manager pkt rcvd on GigabitEthernet1/0/26, length 366
Apr 25 04:45:54.156: VTP LOG RUNTIME: Relaying packet received on trunk Gi1/0/26 - in TRANSPARENT MODE (nc = false)
Apr 25 04:45:54.156: vlan manager pkt rcvd on GigabitEthernet1/0/27, length 99
Apr 25 04:45:54.156: VTP LOG RUNTIME: Relaying packet received on trunk Gi1/0/27 - in TRANSPARENT MODE (nc = false)
Apr 25 04:45:54.156: vlan manager pkt rcvd on GigabitEthernet1/0/27, length 366
Apr 25 04:45:54.156: VTP LOG RUNTIME: Relaying packet received on trunk Gi1/0/27 - in TRANSPARENT MODE (nc = false)
5
  • Can you provide a diagram? Have you looked at debug messages?
    – Ron Trunk
    Apr 24 '16 at 11:31
  • Show output of #show vtp password
    – Pieter
    Apr 24 '16 at 14:26
  • Didn't set the password for VTP
    – Tech
    Apr 24 '16 at 14:33
  • If you've solved this, please answer your own question. Otherwise it will keep popping up in the list.
    – Ron Trunk
    Apr 24 '16 at 16:09
  • Sorry, I can't solve this...
    – Tech
    Apr 24 '16 at 17:00
2

Apparently, your VTP password is incorrect on the 2960X which doesn't work. The MD5 digest on VTP doesn't match on the last (non-working) of the three switches you show. You wrote there is no MD5 checksum error, but there is in the debug output:

Apr 25 04:26:06.207: VTP LOG RUNTIME: MD5 digest failing

You can use the show vtp password command on a switch to show the VTP password you used on the switch. Do this on switches that do work, then on the switch which doesn't work, and you will probably discover that it doesn't exactly match. You can copy it on a working switch, then paste it in the non-working switch.

2
  • The switch doesn't working have a password, but how the password configured on this switch? any idea. If i want to enable the password for VTP , where i want to start configuring ? from client to server OR server to client?
    – Tech
    Apr 25 '16 at 4:08
  • The show vtp password command in enable mode will show you the current password, and the vtp password <password> command in configuration mode will set the VTP password. You must have the password the same on all the switches in a VTP domain, even if it is a blank password.
    – Ron Maupin
    Apr 25 '16 at 4:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.