2

I'm using a HP 1920 Switch with a 3 VLANs configuration combined with a pfSense Firewall. VLAN 1 is configured as Management Interface. If I connect to the switch by cable I can access the Webinterface just fine. But if I connect through VPN (openVPN on pfSense) I can't neither access the Webinterface nor ping the Switch. However I can ping the Switch from the pfSense Firewall using the internal ping tool. And I can ping other devices on the MGMT Net just fine through VPN.

My guess is that the Switch blocks access from IPs outside the MGMT Net, which the VPN tunnel is. I have tried to define an ACL and Authorized IP but no matter what I set there I cannot access the switch Webinterface through VPN.

The network is setup as follows

  • MGMT Net 10.16.1.0/25

  • VPN Tunnel 10.16.1.248/29

Has anyone succeeded to administer an HP 1920 Switch through a VPN tunnel? How can I do this?

1

I ran into a similar issue with a 5412. It worked for us after making sure the switch's default gateway (where you set the switch's IP in the VLAN Mgmt section) was set to the firewall's IP on the management VLAN.

| improve this answer | |
  • Thanks for the hint! Will test and report back as soon as I have access to the Switch. – Pascal Mages May 5 '16 at 11:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.