I am running a pfSense 2.3 box with 4 NICs. Now i have 2 different ISPs (one Cable & one DSL). How Can i configure, that all traffic from LAN1 goes ONLY over WAN1, and all traffic from LAN2 goes ONLY over WAN2? I Dont want any Failover or LoadBalancing, just seperate each Networks "Gateways". Here a simple diagram, on what i try to achieve. enter image description here


2 Answers 2


Instead of ISP IP addresses as gateways, you could use two tier-based gateway teams.
Each gateway team will have the preferred ISP in tier 1, while the other ISP will be in tier 2.

    • ISP1 tier 1
    • ISP2 tier 2
    • ISP2 tier 1
    • ISP1 tier 2

In normal conditions, each LAN will use the tier 1 member of the team.
When ISP1 goes down, ISP2 will be used by both LAN1 and LAN2.
When ISP2 goes down, ISP1 will be used by both LAN1 and LAN2.

  • That sounds interesting and is perhaps a good alternative for me, how do i do that exactly?
    – andy
    Sep 18, 2017 at 10:49
  • 1
    Go to System > Routing > Gateway Groups > Add, use a menaningful name as "TEAM-ISP1" to the group, and define gateway tiers in the Gateway Priority area. You'll find your ISP1 and ISP gateways already there, just set tiers changing from "Never" to "Tier 1" for ISP1 an "Tier 2" for ISP2 in the dropdowns. Save and repeat the same procedure, adding a new gateway group, this time called "TEAM-ISP2", where ISP1 will have "Tier 2" and ISP2 "Tier 1". From this moment on, you can select gateway groups in firewall rules. Sep 18, 2017 at 12:32
  • Perfect that worked and is exactly what i wanted and very simple. Thank you very much!
    – andy
    Sep 19, 2017 at 8:26

You can do that by changing the NAT rules. (This only works for IPv4)

Firewall --> NAT --> Outbound --> "Mode": Manual Outbound NAT rule generation (AON - Advanced Outbound NAT).

Now you can specify which subnet goes over which WAN interface:

Interface --> Choose WAN interface

Source --> Specify LAN subnet

PfSense NAT

enter image description here

  • Thank you for the clear answer. Now i have done that, as you guided. I have switched to Manual Outbound NAT Rule Generation (AON) and deleted all automatic added mappings. Then i set up 2 mappings, for each of my LANs, as you described in your answer. But my LAN2 isnt able to go online. Edit: Can it be, that it is necessary to select the Gateway to use, in Firewall -> Rules -> LAN and Firewall -> Rules -> LAN2 in each of the Default Rules?
    – andy
    May 1, 2016 at 14:35
  • Yes, I believe that using the gateway selection in the firewall rules page is the best way to route LAN1 to WAN1 and LAN2 to WAN2. Try it! May 1, 2016 at 16:33
  • Now i Setup like Quincy said and in Addition set the the Gateways in the Firewall rules page (in LAN1 i set WAN1 as Gateway and in LAN2 i set WAN2 as Gateway). This works, but if WAN1 goes down (unplug cable), then LAN1 is offline, which is correct, but LAN2 seems it cant resolve dns anymore, so no real Internet Connection. What could this be?
    – andy
    May 1, 2016 at 17:26
  • Has someone other any idea?
    – andy
    May 2, 2016 at 8:46
  • I Think you should edit the interface in your advanced setting screen. I added a screenshot to my previous post. (You can find it at System --> General Setup)
    – user22997
    May 2, 2016 at 17:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.