3

i'm trying to connect to my ssh test server that i setup behind a pfsense firewall via nat on port 22.

When I sniff packet on my laptop (WAN side of pfsense) trying to connect to the server, SYN is send, SYN ACK received, but my computer don't care and resend.

Link to the capture : https://www.cloudshark.org/captures/996b00e33150

Have you got idea to keep debugging this problem ?

Thanks

  • Could you possibly add a diagram of your setup with IPs, NAT config and so on ? My best guess based on the capture is that your NAT config is messed up somehow, such that your PC receives a SYN/ACK which doesn't appear to be related to its original SYN, and just ignores it. However, that would presume that the capture is actually taking place on the server side of the pfsense, not the client side, given that everything looks good in the packets that we do see. – Jeremy Gibbons May 11 '16 at 6:28
  • yeah it's possibe the config of the NAT is wrong given how much i tweak it, but i never got it to work, that's why i take a capture. And yes, the capture is indeed made on my laptop on wifi, and i really don't know why it didn't work, i'm running out of question to google here ... – aurel May 11 '16 at 11:12
4

Found it !

It's a bug when running pfsense virtualized -> https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=165059

Workaround is to disable hardware checksum offload box under System > Advanced on the Networking tab of pfsense.

| improve this answer | |
  • Thanks for getting me on the right track, here's some more info: forum.pfsense.org/index.php?topic=88467.0 – sjas Nov 7 '16 at 15:49
  • i am facing same problem, i have ESXi server with pfsense. for one VM it works only. but for all others i get tcp restranmission, even though i have disabled hardware checkcum – Farhan Sep 3 '18 at 20:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.