1

I am trying to monitor network devices in our company using SCOM. So far the devices are not responding to SNMP request. These devices support SNMP. Firewall is not an issue since the monitoring server is already in the company's network. Trying the command below gave the following result for one device:

~$ snmpget -v 1 -c ro345iu5672 11.248.154.10 .1.3.6.1.2.1.1.1.0
Timeout: No Response from 11.248.154.10.

Additional research suggested that the target SNMP device needs to enable the whole system MIB/OID-tree to be discoverable in SCOM. If any of the following OIDs are missing, you will not be able to discover the device:

• 1.3.6.1.2.1.1.1.0 --> system.sysDescr
• 1.3.6.1.2.1.1.2.0 --> system.sysObjectID
• 1.3.6.1.2.1.1.4.0 --> system.sysContact
• 1.3.6.1.2.1.1.5.0 --> system.sysName
• 1.3.6.1.2.1.1.6.0 --> system.sysLocation

How can I enable these OID's for a network device?

  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer. – Ron Maupin Aug 14 '17 at 2:41
1

There is pretty simple scenario to access device via SNMP and get information you want.

  1. Enable SNMP on the device, select SNMP version (v1, v2c, v3), set read/write community (it's like "password" in SNMP)

  2. Find out MIB file for that device vendor/product(usually developers include .mib files with firmware versions/updates)

  3. Check exactly what that device can "tell" you via SNMP (check MIB file), it's usually easier to do with some software like Castle Rock SNMPc Network Manager or some else products, that can "scan" device using IP address, mib file, and communities you wrote in. (yeah, this is for win* systems, but I'm pretty sure there is *nix alternatives).

After you have found what exactly you need to know - you will know OID, and should use the command you wrote above to get info you need.

Now, responding for your situation. I guess you should do steps in this order:

  1. Check network connection to this device (if we are assuming that ping is working - than you should use check 161 port as mentioned above by Orlando.)

  2. Check that your device have SNMP=enabled in configuration. Check SNMP version and communities.

  3. Check that your device know something about OID you are writing there (but I guess it's not the case cause there should be some respond at all, even with wrong OID. imo.)

| improve this answer | |
  • Thank you so much @Marat. I will try this out and see the result. – Fokwa Best May 12 '16 at 13:25
  • Hello, I have contacted the network admin, he said SNMP is enabled on the device, port 161 is ok, firewall isn't an issue, community string is ok, etc. What else can be the problem? – Fokwa Best May 12 '16 at 15:19
  • Ok, I've just installed virtual debian with access to the network with a lot of switches. I tried 4 variations. 1. snmpget -v 1 -c 12345 10.1.235.10 .1.3.6.1.2.1.1.1.0 (Correct IP, wrong SNMP version, wrong community, wrong OID) - Timeout. No response from 10.1.235.10 2. snmpget -v 2c -c 12345 10.1.235.10 .1.3.6.1.2.1.1.1.0 (Correct IP, wrong community, wrong OID) - Timeout. No response from 10.1.235.10 – Marat Fakhrutdinov May 12 '16 at 17:08
  • 3. snmpget -v 1 -c *** 10.1.235.10 .1.3.6.1.2.1.1.1.0 (Correct IP, correct community, wrong SNMP version, wrong OID) Error in packet. Reason: (noSuchName) there is no such variable name in this MIB. Failed object: iso.3.6.1.2.1.1.1.0 4. snmpget -v 2c -c *** 10.1.235.10 .1.3.6.1.2.1.1.1.0 (Correct IP, correct community, correct SNMP version, wrong OID) iso.3.6.1.2.1.1.1.10 = No Such Instance currently exists at this OID 5. snmpget -v 2c -c *** 10.1.235.10 1.3.6.1.2.1.1.3.0 (Correct IP, correct community, correct SNMP version, correct OID) iso.3.6.1.2.1.1.3.0 = 106 days, 14:15:50.00 – Marat Fakhrutdinov May 12 '16 at 17:15
  • According to this - you have 2 variations. 1. You can't see device via network (no "echo reply" so device in "unreachable"). 2. You type community wrong. It should be exactly match with community settings on the device. – Marat Fakhrutdinov May 12 '16 at 17:17
1

You probarly need to enable SNMP on your devices, with the correct community, unless you do that, no response could be received by your SCOM. If you already done this, then you can check on the logs of your devices to see if SNMP request are received, and some kind of error, if happens. It is not, you need to check if the SNMP default port, 161, are been filtered in some place. Remember, this is only a global answer, every equipment have it owns steps to configure SNMP. If yow can't resolve, you can edit your question and put devices model.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.