1

I have two ebgp peers connected to my quagga 1.0.20160315 router.

One of those peers (peer1) is advertising routes with flag 0x800 (Optional Non-Transitive) in the MP_REACH_NLRI path attribute. Also the next hop is marked as Optional Non-Transitive.

My quagga router is not advertising this route to the other peer2 and I suspect this is because of the Non-Transitive flags in the path attribute.

Is their a way to override non-transitive flag in incoming routes and redistribute them to all the other peers?

Thanks in advance for the help. Regards

Update I got it working by using a route map and re-writing the bgp next hop. Original route was not advertised because of Non Transitive flags.

router bgp 64496  
bgp router-id 192.168.56.1  
network 192.1.1.0/24  
 !  
 redistribute connected  
 neighbor 192.168.20.201 remote-as 64496  
 neighbor 192.168.20.201 route-reflector-client  
 neighbor 192.168.20.201 update-source 192.168.20.1  
 neighbor 192.168.20.201 soft-reconfiguration inbound  
redistribute connected  
 neighbor 192.168.56.202 remote-as 64498  
 neighbor 192.168.56.202 update-source 192.168.56.1  
 neighbor 192.168.56.202 soft-reconfiguration inbound  
 neighbor 192.168.56.202 route-map set-nexthop out  
!  
route-map set-nexthop permit 10  
 set ip next-hop 192.168.56.1  
 set metric 200  
 set local-preference 5  
!   
1

No, you cannot change the flag. Attribute MP_REACH_NLRI is defined to be Optional Non-Transitive in RFC4760. What kind of routes you are trying to advertise?

Update Neighbor to 192.168.20.201 in same AS(64496) is iBGP, not eBGP. You should be able to fix it easily by changing local AS or neighbor AS.

The reason why it wasn't working before you set nexthop is that Quagga router received routes from 192.168.20.201 but their nexthop cannot be used. You can use neighbor <peer> next-hop-self to fix it instead of route-map.

Also if you want to run eBGP for all routers, you don't need to configure neighbor <peer> route-reflector-client which is for iBGP.

3
  • The routes are igp origin ipv4 routes advertised by opendaylight sdn controller software bgp peer with MP_REACH_NLRI and next hop as non-transitive. The problem is that quagga is not further advertising this received route to other peers. With the same bgpd.conf configuration for another quagga peer, quagga router is further advertising routes from that peer. So it does not seem to be a configuration issue. Is their still a way adding something into conf file that such routes could be advertised? – Sidhant101 May 13 '16 at 10:02
  • I see. You should to post your config and update your question. :) – Pue-Tsuâ May 13 '16 at 12:42
  • I got it working by rewriting the next hop using a route-map. Thanks for the help :) – Sidhant101 May 13 '16 at 13:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.