1

I'm new to cisco and currently studying for a certification, this is just my way of practicing what I learned.. Currently I'm in a standstill because I can't seem to understand what is happening, or maybe my NAT fundamentals is off. Anyways please refer to the topology I created via Packet Tracer

enter image description here

CR running-config

!
!
!
interface GigabitEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/2
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/3/0
 ip address 205.112.2.1 255.255.255.252
 ip nat outside
!
interface Serial0/3/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip nat pool mypool 172.16.2.1 172.16.2.31 netmask 255.255.255.224
ip nat inside source list 50 pool mypool overload
ip classless
!
ip flow-export version 9
!
!
access-list 50 permit 192.168.1.0 0.0.0.255
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

ISP running-config

interface GigabitEthernet0/0
 ip address 210.125.35.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/2
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/3/0
 ip address 205.112.2.2 255.255.255.252
 clock rate 64000
!
interface Serial0/3/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 205.112.2.1 
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

Now, CR is my company router, connected via serial interface, also this is where i put my NAT configuration. ISP's is just a static route back to CR for ping purposes.

What i did to verify this setup is via ping on PC0/PC1/PC2 to Server0 however it is unreacheable (yep understandable because CR has not route to 210.125.35.0 network) but considering NAT was configured on that router i expected it to be translated via the public IP and route it, at this point im really confused. Now another test i did was to ping the 205.112.2.2 interface on ISP router it boom it translated (confirmed via show ip nat translation). At this point im sure im missing something because im really confused at this point..

Can somebody help me clear things up?

EDIT

As @Ron Maquin said, it is a routing problem, i added a default route, but the nat translation is incrementing when i do continuous ping from PC0. As what i know, it will just reuse the assigned port to the translated IP (in this case PC0). Please correct me if im wrong, refer also to the show ip nat translation output

CR#show ip nat translations 
Pro  Inside global     Inside local       Outside local      Outside global
icmp 172.16.2.1:27     192.168.1.2:27     210.125.35.110:27  210.125.35.110:27
icmp 172.16.2.1:28     192.168.1.2:28     210.125.35.110:28  210.125.35.110:28
icmp 172.16.2.1:29     192.168.1.2:29     210.125.35.110:29  210.125.35.110:29
icmp 172.16.2.1:30     192.168.1.2:30     210.125.35.110:30  210.125.35.110:30
icmp 172.16.2.1:31     192.168.1.2:31     210.125.35.110:31  210.125.35.110:31
icmp 172.16.2.1:32     192.168.1.2:32     210.125.35.110:32  210.125.35.110:32
icmp 172.16.2.1:33     192.168.1.2:33     210.125.35.110:33  210.125.35.110:33
icmp 172.16.2.1:34     192.168.1.2:34     210.125.35.110:34  210.125.35.110:34
icmp 172.16.2.1:35     192.168.1.2:35     210.125.35.110:35  210.125.35.110:35
icmp 172.16.2.1:36     192.168.1.2:36     210.125.35.110:36  210.125.35.110:36
icmp 172.16.2.1:37     192.168.1.2:37     210.125.35.110:37  210.125.35.110:37
icmp 172.16.2.1:38     192.168.1.2:38     210.125.35.110:38  210.125.35.110:38
icmp 172.16.2.1:39     192.168.1.2:39     210.125.35.110:39  210.125.35.110:39
icmp 172.16.2.1:40     192.168.1.2:40     210.125.35.110:40  210.125.35.110:40
icmp 172.16.2.1:41     192.168.1.2:41     210.125.35.110:41  210.125.35.110:41
icmp 172.16.2.1:42     192.168.1.2:42     210.125.35.110:42  210.125.35.110:42
icmp 172.16.2.1:43     192.168.1.2:43     210.125.35.110:43  210.125.35.110:43
icmp 172.16.2.1:44     192.168.1.2:44     210.125.35.110:44  210.125.35.110:44
icmp 172.16.2.1:45     192.168.1.2:45     210.125.35.110:45  210.125.35.110:45
icmp 172.16.2.1:46     192.168.1.2:46     210.125.35.110:46  210.125.35.110:46
icmp 172.16.2.1:47     192.168.1.2:47     210.125.35.110:47  210.125.35.110:47
2
  • You need to provide more information. For instance, the router configuration. Edit your question to include any relevant information.
    – Ron Maupin
    May 24, 2016 at 14:33
  • added running-config
    – lemoncodes
    May 24, 2016 at 14:37

1 Answer 1

2

You have a routing problem. If the CR router does not have a route to tell it to send the traffic destined for the 210.125.35.0 network to the outside interface, it just drops it.

Traffic is only translated from the inside interface when it is going to an outside interface, but that traffic never makes it to the outside interface; the router doesn't know what to do with it, so it just drops it. This is expected behavior for a router.

4
  • i see.. what i did what execute ip route 0.0.0.0 0.0.0.0 205.112.2.2 on CR.. and it works.. traced the packet as it was leaving CR route src IP is 172.16.2.1 and dst IP is as expected.. i wanted to clarify -> even though you have a static route it will still translate to the public ip address then after it will route to the next hop? just wanted to confirm if what i understand is correct
    – lemoncodes
    May 24, 2016 at 14:54
  • btw please refer to my edited question above..
    – lemoncodes
    May 24, 2016 at 15:11
  • Any traffic in a single flow will keep the address. The problem with ping is that it is ICMP, and each packet sent will do what you observe. If you create a TCP connection, all the packets sent in that connection are a single flow, and they will all have the same address. You should not edit the question to change it in this way. This is a new question that should be asked as a new question. When you keep changing the question, the answers you get no longer match the question.
    – Ron Maupin
    May 24, 2016 at 15:23
  • ohh i see understood.. @question.. okay sorry about that .. thanks
    – lemoncodes
    May 24, 2016 at 15:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.