1

I tried to establish an old switch in site, but VTP is not working.

Show cdp neighbor 

Got the next switch with this command.

Model: WS-C2960-24TC-L Version : 12.2(53)SE2

I tried to add the management VLAN and give it an IP address.

How can I debug the connection?

version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Switch
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$49nA$xGugzBL.MidsIvXB.
!
no aaa new-model
system mtu routing 1500
authentication mac-move permit
ip subnet-zero
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
interface FastEthernet0/1
!
interface FastEthernet0/24
switchport mode trunk
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2 
!
interface Vlan1
no ip address
no ip route-cache
!
interface Vlan150
ip address 10.10.150.50 255.255.255.0
no ip route-cache
!
ip default-gateway 10.10.150.1
ip http server
ip http secure-server
ip sla enable reaction-alerts
!
line con 0
line vty 0 4
password 7 08974A351F8G5K483956
login
line vty 5 15
login
!
end

I tried with another switch, and it's working fine.

Switch#sh vtp sta
VTP Version capable             : 1 to 3
VTP version running             : 1
VTP Domain Name                 : ABC
VTP Pruning Mode                : Disabled
VTP Traps Generation            : Disabled
Device ID                       : xxxx.xxxx.xxxx
Configuration last modified by 0.0.0.0 at 3-1-93 00:04:03

Feature VLAN:
--------------
VTP Operating Mode                : Client
Maximum VLANs supported locally   : 255
Number of existing VLANs          : 6
Configuration Revision            : 1
MD5 digest                        : 0xB9 0x07 0xEE 0xE3 0x27 0xEC 0xF7 0x33
                                    0x98 0x81 0x0A 0xA3 0x32 0xE9 0xD2 0xDF
  • Tried to reset the switch
  • Replace with another switch, and it's working fine.

Working switch VTP STATUS

SW04#sh vtp sta
VTP Version capable             : 1 to 3
VTP version running             : 1
VTP Domain Name                 : ABC
VTP Pruning Mode                : Disabled
VTP Traps Generation            : Disabled
Device ID                       : xxxx.xxxx.xxxx
Configuration last modified by xxx.xxx.xxx.xxx at 5-17-16 09:33:54

Feature VLAN:
--------------
VTP Operating Mode                : Client
Maximum VLANs supported locally   : 1005
Number of existing VLANs          : 12
Configuration Revision            : 16
MD5 digest                        : 0x39 0x28 0x36 0x47 0xDE 0xDC 0xBE 0x26
                                    0x6E 0x16 0xD9 0x56 0xCC 0x4D 0xF8 0x7B
7
  • You need to provide more information. Please provide the configurations of both switches.
    – Ron Trunk
    May 28 '16 at 10:59
  • If you're trying to get vtp to work, you need to set the domain name and vtp mode.
    – Ron Trunk
    May 28 '16 at 14:11
  • It's I already give @Ron trunk
    – Tech
    May 28 '16 at 14:16
  • I don't see it in your config. Have you tried debug VTP?
    – Ron Trunk
    May 28 '16 at 14:23
  • @RonTrunk, much to the chagrin of auditors everywhere, the VTP configuration doesn't show up in the running configuration. You must specifically show the VTP status. @Tech, put in the show vtp status for both a working and non-working switch.
    – Ron Maupin
    May 28 '16 at 15:43
1

Your problem is that the VTP passwords don't match.

On the non-working switch:

MD5 digest                        : 0xB9 0x07 0xEE 0xE3 0x27 0xEC 0xF7 0x33
                                    0x98 0x81 0x0A 0xA3 0x32 0xE9 0xD2 0xDF

On the working switch:

MD5 digest                        : 0x39 0x28 0x36 0x47 0xDE 0xDC 0xBE 0x26
                                    0x6E 0x16 0xD9 0x56 0xCC 0x4D 0xF8 0x7B

You can verify this by using the show vtp password command on each switch.

4
  • The values in MD5 digest should be same?
    – Tech
    May 29 '16 at 5:13
  • The MD5 values are the hash of the VTP password. Use the show vtp password command to see that the passwords are not the same. You can copy the password from a working switch, and paste it in on a non-working switch. It could be a simple as having a space at the beginning or end of the password.
    – Ron Maupin
    May 29 '16 at 5:15
  • I didn't set password for VTP. I used the command no vtp password
    – Tech
    May 29 '16 at 7:30
  • A null password is a password, too. All switches in the VTP domain need to have the same domain name and password. Your VTP domain names are the same in the working and non-working switches, but the VTP passwords are different. The non-working switch must have the same VTP password as the other switches in the VTP domain if you want it to participate in VTP.
    – Ron Maupin
    May 29 '16 at 8:21
0

VTP Configuration Guidelines

This section provides some guidelines for the configuration of VTP in the network.

  • All switches have the same the VTP domain name, unless the network design insists for different VTP domains. Note: Trunk negotiation does not work across VTP domains. Refer to the Data Traffic Blocked between VTP Domains section of Troubleshooting VLAN Trunk Protocol (VTP) for more information.

  • All switches in a VTP domain must run the same VTP version. All switches in a VTP domain has the same VTP password, if there is any.

  • All VTP Server switch(es) should have the same configuration
    revision number and it should also be the highest in the domain.

  • When you move a VTP mode of a switch from Transparent to Server,
    VLANs configured on the VTP Transparent switch should exist on the Server switch.

    switch#vlan database

    switch(vlan)#vtp domain domain-name

    switch(vlan)#vtp {client | server | transparent}

2
  • Above configuration, even I tried to add management vlan and it's interface,
    – Tech
    May 29 '16 at 3:33
  • from enable mode, NOT configuration mode, type vlan database and hit Enter. May 29 '16 at 4:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.