1

I currently have 1x Juniper ex3300 and 1x HP ProCurve 2848 forming the core of my network with vlans 1, 10, 20 and 30 being trunked between them on ports 46-47. The ex3300 acts as the DHCP server for all vlans and routes between them and the internet.

Wireless APs (airport express/extreme) connect directly to each of these switches in most cases but in some, Mikrotik RB260gs's are connected via trunk links with the same vlans across them.

The directly connected APs function fine and the switchports can be placed in any VLAN and retain connectivity. The RB260gs functions correctly (serves up DHCP addresses related to VLAN, full connectivity) when my laptop is plugged in. When I plug any other device into the same port, however, the device does not receive a DHCP address and there is no connectivity

I have tested this so far with an Onkyo AV Receiver, Airport Extreme, Airport Express, all of which don't pick up a DHCP address. Two windows machines do pick up DHCP (one of which only has a clean windows install on it).

Ive got nothing here. Anyone lend a hand?

[UPDATE] - Configs Mikrotik VLAN Config

HP CONFIG

hostname "MUST-CSW2-HP2848"
mirror-port 39
interface 6
   name "Captains_Cabin_Express"
exit
interface 11
   name "VIP_AP"
exit
interface 20
   name "ASW1-Master"
exit
ip default-gateway 172.20.11.254
snmp-server community "public" Unrestricted
vlan 1
   name "DEFAULT_VLAN"
   ip address dhcp-bootp
   tagged 10
   no untagged 1-9,11-48
   exit
vlan 10
   name "Ship"
   untagged 1-19,21-38,40-44
   ip address 172.20.11.253 255.255.254.0
   tagged 20,45-48
   exit
vlan 20
   name "Crestron"
   ip address 172.20.20.253 255.255.255.0
   tagged 20,45-48
   exit
vlan 30
   name "Guest"
   untagged 39
   ip address 172.20.30.253 255.255.255.0
   tagged 20,45-48
   exit
vlan 99
   name "Management"
   exit
interface 20
   monitor
   exit
spanning-tree

JUNIPER CONFIG

****************output omitted**********************

        dhcp {
            traceoptions {
                file dhcp_logfile;
                level all;
                flag all;
            }
            pool 172.20.10.0/23 {
                address-range low 172.20.10.50 high 172.20.11.149;
                name-server {
                    8.8.8.8;
                    8.8.4.4;
                }
                router {
                    172.20.11.254;
                }
            }
            pool 172.20.30.0/24 {
                address-range low 172.20.30.25 high 172.20.30.225;
                name-server {
                    8.8.8.8;
                    8.8.4.4;
                }
                router {
                    172.20.30.254;
                }
            }
            pool 172.20.20.0/24 {
                address-range low 172.20.20.50 high 172.20.20.225;
                name-server {
                    8.8.8.8;
                    8.8.4.4;
                }
                router {
                    172.20.20.254;
                }
            }
        }
    }

****************output omitted*************************

    ge-0/0/44 {
        unit 0 {
            family ethernet-switching {
                port-mode trunk;
            }
        }
    }
    ge-0/0/45 {
        unit 0 {
            family ethernet-switching {
                port-mode trunk;
                vlan {
                    members [ Ship Guest Crestron-Control ];
            }
        }
    }
    ge-0/0/46 {
        unit 0 {
            family ethernet-switching {
                port-mode trunk;
                vlan {
                    members [ Ship Guest Crestron-Control ];
            }
        }
    }
    ge-0/0/47 {
        unit 0 {
            family ethernet-switching {
                port-mode trunk;
                vlan {
                    members [ Ship Guest Crestron-Control ];
                }
            }
        }

**************output omitted******************

    vlan {
        unit 0 {
            family inet;
        }
        unit 1 {
            family inet;
        }
        unit 10 {
            family inet {
                address 172.20.11.254/23;
            }
        }
        unit 20 {
            family inet {
                address 172.20.20.254/24;
            }
        }
        unit 30 {
            family inet {
                address 172.20.30.254/24;
            }
        }
        unit 100 {
            family inet {
                address 172.20.100.14/28;
            }
        }
    }
}

***************output omitted******************

routing-options {
    static {
        route 0.0.0.0/0 next-hop 172.20.100.1;
    }
}
protocols {
    igmp-snooping {
        vlan all;
    }
    rstp {
        bridge-priority 0;
    }
    lldp {
        interface all;
    }
    lldp-med {
        interface all;
    }
}
ethernet-switching-options {
    storm-control {
        interface all;
    }
}
vlans {
    Crestron-Control {
        description "Crestron Network Resources";
        vlan-id 20;
        interface {
            ge-0/0/47.0;
            ge-0/0/44.0;
            ge-0/0/45.0;
            ge-0/0/46.0;
        }
        l3-interface vlan.20;
    }
    Guest {
        description "Guest Network Resources and User Devices";
        vlan-id 30;
        interface {
            ge-0/0/47.0;
            ge-0/0/46.0;
            ge-0/0/45.0;
            ge-0/0/44.0;
            ge-0/0/10.0;
        }
        l3-interface vlan.30;
    }
    Internet_Connection {
        description "Connection to Peplink30 via Bridge_MAIN";
        vlan-id 100;
        interface {
            ge-0/0/0.0;
        }
        l3-interface vlan.100;
    }
    Management {
        vlan-id 99;
        l3-interface vlan.0;
    }
    Ship {
        description "Hardware and Crew";
        vlan-id 10;
        interface {
            ge-0/0/47.0;
            ge-0/0/11.0;
            ge-0/0/12.0;
            ge-0/0/13.0;
            ge-0/0/14.0;
            ge-0/0/15.0;
            ge-0/0/16.0;
            ge-0/0/17.0;
            ge-0/0/18.0;
            ge-0/0/19.0;
            ge-0/0/29.0;
            ge-0/0/44.0;
            ge-0/0/45.0;
            ge-0/0/46.0;
        }
        l3-interface vlan.10;
    }
    default {
        vlan-id 1;
        interface {
            ge-0/0/47.0;
        }
        l3-interface vlan.1;
    }
}
poe {
    interface all;
}
  • It may help to show the configuration of your Juniper. – Teun Vink May 30 '16 at 12:28
  • Sure although I dont think its the juniper config as I can connect an access point directly (or via the HP) in any VLAN and get the correct DHCP offer. I'm pretty sure its a config issue of the Mikrotik (config also posted) or the Mikrotik-HP connection. – eto.ttnflt May 30 '16 at 13:39
  • also, please let me know if you wanted the full configuration. I'm new to the boards and dont know what is considered spam. – eto.ttnflt May 30 '16 at 13:58
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer. – Ron Maupin Aug 14 '17 at 4:23
3

If the networks are routed through your HP (do not have a Layer2 connection by being in the same VLAN as their DHCP Server), you need to add a IP Helper in order to allow the DHCP Broadcasts to reach their respective DHCP Server.

For you an interface-config on the may look like this then:

vlan 30
   name "Guest"
   untagged 39
   ip address 172.20.30.253 255.255.255.0
   ip helper-address x.x.x.x (IP Address of DHCP Server)
   tagged 20,45-48
exit

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.