1

I have a setup where the ASA 5510 is acting as the default gateway for devices connected to an L2 switch connected to the ASA.

The basic setup is:

ASA -> L2 switch -> Servers

The servers have their gw set to the subinterface ip on the ASA but for some reason, the servers cannot be pinged from the switch itself nor from the firewall.

Here is the config of the ASA:

 interface Ethernet0/0
 nameif outside
 security-level 0
 ip address 1.1.1.100 255.255.255.240 
!
interface Ethernet0/1
 nameif inside
 security-level 100
 ip address 10.99.1.1 255.255.255.0 
!
interface Ethernet0/1.102
 vlan 102
 nameif internal
 security-level 100
 ip address 10.1.2.2 255.255.255.0

the default gw on the ASA goes out to the provider uplink.

the default gw on the switch is the ASA. the port on the switch connected to the fw is setup as a trunk.

The config for the L2 switch is basically this.

vlan 1

vlan 102

int vlan 1
ip add 10.99.1.2 255.255.255.0

int g0/1
desc To-ASA-5510
switchport trunk encap dot1q
switchport mode trunk

int g0/2
switchport access vlan 102

int g0/3
switchport access vlan 102

ip default-gateway 10.99.1.1

The servers are connected to ports 2+3.

What am I missing here? Are there specific firewall rules that need to be created at all?

Thanks

5
  • Please give configuration from the L2 Switch. Also is ICMP activated? I am currently working on the same Setup as you, with a 5512X ;-) Jun 9, 2016 at 12:20
  • I edited my original post to include l2 switch config. Jun 9, 2016 at 20:16
  • Look like problem between ASA and your Switch trunk, You put IP address on interface Ethernet0/1 and later you create sub-interface on it interface Ethernet0/1.102 that looks wrong. You don't put ip address on interface Ethernet0/1 if you create VLAN on it, that was i believe, also on int g0/1 you need to allow VLAN on trunk
    – Satish
    Jun 9, 2016 at 20:33
  • Shouldn't he define on G0/1 on Switch the native VLAN and also optional the switchport access on this port? But I'm not completely sure. Jun 10, 2016 at 7:26
  • Did any answer help you? if so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer.
    – Ron Maupin
    Aug 9, 2017 at 17:09

1 Answer 1

1

There are two issues here:

  1. You are trying to ping from VLAN 1 (switch) to VLAN 102 (servers).
    The ASA won't forward traffic between interfaces of the same security level unless you explicitly allow it.

same-security-traffic permit inter-interface

  1. The ASA blocks ICMP by default. You have to allow it.
icmp enable inside
icmp enable internal

You can also look in the ASA log to see what it is blocking and why.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.