1

I have HP EI 5500 L3 switch, I am trying to start HTTPS on switch but it give me error

Error: Failed to enable HTTPS server.

This might be because of SSL certificate was not there on switch.

Can anyone help me on this.??

  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer. – Ron Maupin Aug 13 '17 at 21:21
1

Depending on what version of Comware you are using, you might need to use a CA Server rather than a generated selfsigned certificate.

Early versions of Comware 3 and 5 seem to need a CA while later versions of Comware 5 and Comware version 7 can use a self signed certificate.

Looking at the configuration guide for the 5500 it states the following:

Enabling the HTTPS service triggers an SSL handshake negotiation process. During the process, if the local certificate of the device exists, the SSL negotiation succeeds, and the HTTPS service can be started properly. If no local certificate exists, a certificate application process will be triggered by the SSL negotiation. Because the application process takes much time, the SSL negotiation often fails and the HTTPS service cannot be started normally. In that case, execute the ip https enable command multiple times to start the HTTPS service.

So if the negotiation does not start which gives you your error, trying using the ip https enable multiple times to start the service and begin the certification application process.

You can view the state of HTTPS using display ip https

You can find more information using the HP 5500 configuration guide which you can find the link to here (PDF document)

If you need to configure https with a CA server, you can find the complex set of steps to do this here

Hope this helps you on your quest.

SleepyMan

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.