1

I'm currently designing a terminal-server architecture, using KVM-Over-IP technology (I'm using Gefen devices) where I have four VLANs:

  • One VLAN for the displays at 192.168.240.0/24
  • Three VLANs for the servers. Why three? Because there are three kinds of servers and they're grouped together. This is imposed and cannot be changed. They're at .241.0, .242.0 and .243.0 respectively.

I'm using a Cisco 3750G Layer 3 Switch. I've configured all the VLANs with their gateways (.1) and there's proper connectivity between the devices. So far so good. The configuration is as follows (this is an excerpt, the rest are the default values)

ip routing
!

interface GigabitEthernet1/0/1
 switchport access vlan 2
!
interface GigabitEthernet1/0/2
 switchport access vlan 10
!
interface GigabitEthernet1/t0/3
 switchport access vlan 20
!
interface GigabitEthernet1/0/4
 switchport access vlan 30
!
interface Vlan2
 ip address 192.168.240.1 255.255.255.0
!
interface Vlan10
 ip address 192.168.241.1 255.255.255.0
!
interface Vlan20
 ip address 192.168.242.1 255.255.255.0
!
interface Vlan30
 ip address 192.168.243.1 255.255.255.0
!

Now, the KVM devices (these Gefen DVI KVM devices) cannot auto discover other KVM devices in different VLANs. That's to be expected, because broadcast messages do not cross VLAN boundaries. After further investigation, looks like these devices use multicast groups to annonunce themselves, using standard TCP connections afterwards to stablish the video transmission.

In order to fix the problem, I've enabled multicast-routing distributed and also tried activating sparse-dense mode. Using wireshark with port mirroring I can see some Membership Report messages from the devices within a VLAN, and PIM protocol messages coming from the VLAN interface (.1), but the devices fail to see each other still.

So, from scratch, how should I configure the 3750G so multicast traffic is shared between VLANs?

Edit: So far I've tried setting up multicast-routing as per the manual (section 47-12):

ip multicast-routing distributed

On each vlan interface:

ip pim sparse-dense-mode

IGMP is enabled by default. This does nothing. I've also tried using MVR but I'm not sure if that's the proper tool for it.

3
  • You need to edit your question to include the switch configuration, otherwise we are guessing (opinions) where you went wrong, and opinion-based answers are explicitly off-topic here.
    – Ron Maupin
    Jun 20 '16 at 14:07
  • I've added an excerpt of the configuration, the other options are in their default value. Jun 20 '16 at 14:46
  • I don't see where you have enabled multicast routing, or any of the other configurations required to make multicast routing work. Your question claims that you have done some of that. What we want to see is what you have tried, and then we can see where you went wrong.
    – Ron Maupin
    Jun 20 '16 at 14:57
2

To get PIM to work on the cisco switches you can either globally set the multicast to traverse all the VLAN's using the following command:

configure
ip igmp snooping 
bridge multicast filtering

If you wanted to perform it only on certain VLAN's, you will need to configure each vlan interface like so.

configure
ip multicast
ip igmp
ip pim sparse

Then configure each interface with

interface vlan x
ip igmp
ip pim

Also, looking quickly at the link to Gefen product you have provided, it states that jumbo frames of 8K need to be enabled. Just in case this is something that is also causing an issue for you.

Hope this helps you on your quest.

SleepyMan

1
  • I think those commands are not compatible with my Catalyst 3750 switch. I've tried similar ones (I've mentioned them in my original question) but it doesn't work. Jun 21 '16 at 11:19

Not the answer you're looking for? Browse other questions tagged or ask your own question.