4

We have a Cisco 2921 connected to an T1 ISDN PRI with Call Manager Express. We are using CP8861 SIP phones. Everything works fine, calling in and out. To better illustrate the problem here's an example: Bob has a DID extension 101. He wants to forward calls from his extension to his cellphone 9.......... when he chooses the Forward All option on the phone. Ana has extension 102, she calls Bob at extension 101 and the call forwards to his cellphone. However, when Bob's customer Charlie calls him from the PSTN to his DID extension, Charlie gets a message saying "This phone number is not available".

Any ideas? In short, phone can forward calls from internal extensions to cellphones but not calls from the PSTN.

Omitted some lines with private information.

!
version 15.6
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
!
boot-start-marker
boot-end-marker
!
!
card type t1 0 0
!
no aaa new-model
ethernet lmi ce
network-clock-participate wic 0
!
!
!
!
!
!
!
!
!
!
!
!
no ip domain lookup
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-ni
!
!
!
voice-card 0
!
!
!
voice service voip
 allow-connections sip to sip
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 sip
  registrar server expires max 1200 min 300
!
!
!
!
voice register global
 mode cme
 source-address 10.0.4.10 port 5060
 max-dn 100
 max-pool 50
 load 8841 sip88xx.11-5-1-18
 load 8861 sip88xx.11-5-1-18
 load 8831 sip88xx.11-5-1-18
 authenticate register
 authenticate realm cisco.com
 dialplan-pattern 1 786165.... extension-length 4
 tftp-path flash:
 create profile sync 0006163776915567
!
voice register dn  1
 number 6475
 name Bob
 label 6475 Bob
 call-forward b2bua all 97864238593
!
voice register pool  1
 busy-trigger-per-button 2
 id mac 40A6.E8B1.01DF
 type 8861
 number 1 dn 1
 username 01DF password cisco
 codec g711ulaw
!
redundancy
!
!
controller T1 0/0/0
 cablelength long 0db
 pri-group timeslots 1-24
!
!
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface ISM0/0
 no ip address
 shutdown
 !Application: CUE Running on ISM
!
interface GigabitEthernet0/1
 ip address 10.0.4.10 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface ISM0/1
 description Internal switch interface connected to Internal Service Module
 no ip address
!
interface Serial0/0/0:23
 no ip address
 encapsulation hdlc
 isdn switch-type primary-ni
 isdn incoming-voice voice
 no cdp enable
!
interface Vlan1
 no ip address
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 10.0.4.1
!
!
!
tftp-server flash:kern88xx.11-5-1-18.sbn
tftp-server flash:fbi88xx.BE-01-010.sbn
tftp-server flash:rootfs88xx.11-5-1-18.sbn
tftp-server flash:sip88xx.11-5-1-18.loads
tftp-server flash:vc488xx.11-5-1-18.sbn
!
control-plane
!
!
voice-port 0/0/0:23
!
voice-port 0/1/0
!
voice-port 0/1/1
!
voice-port 0/1/2
!
voice-port 0/1/3
 !
 !
 !
 !
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
dial-peer voice 1 pots
 destination-pattern 9[2-9]..[2-9]......$
 port 0/0/0:23
 forward-digits 10
!
dial-peer voice 2 pots
 destination-pattern 91[2-9]..[2-9]......$
 port 0/0/0:23
 forward-digits 10
!
dial-peer voice 3 pots
 destination-pattern 911
 port 0/0/0:23
 forward-digits 3
!
dial-peer voice 4 pots
 destination-pattern 9911
 port 0/0/0:23
 forward-digits 3
!
dial-peer voice 5 pots
 destination-pattern 9011T
 port 0/0/0:23
 prefix 011
!
!
!
!
gatekeeper
 shutdown
!
!
!
  • 1
    This is a configurable restriction in CME to prevent toll fraud. Search on "Trunk-to-Trunk Transfer Blocking" – Ron Trunk Jun 20 '16 at 21:15
  • @RonTrunk Thanks for pointing me to the right direction, looks like this is what I'm dealing with – Mr. Cebollin Jun 20 '16 at 21:31
  • @RonTrunk Hello, it is not it. The restriction is not configured. I read on the documentation that because of backwards compatibility, if it's not set with the command "transfer-pattern [pattern]" in telephony service then all forwarding and transfers are allowed by default. – Mr. Cebollin Jun 21 '16 at 23:23
  • I believe that it is on by default with the more recent versions. – Ron Maupin Jul 26 '16 at 16:30
  • Cisco Unified CME VoIP Call Forwarding Options. Also try adding a 1 after the 9? – Ronnie Royston Jul 26 '16 at 17:35
2

Mr.Cebollin,

I had the same issue and this is because the E1 Service Provider will not allow it as a restriction to avoid Toll-Fraud. In my case to make it work, I used the highlighted option. Hope this helps.

ephone-dn 5 dual-line
number XXXX
**snr calling-number local**
snr [Mobile Number] delay 10 timeout 24 cfwd-noan 500
snr ring-stop
call-forward noan 500 timeout 24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.