2

As I understand, when no auto-summary command is used, the network command could include all the interface with IP addresses included in the classful network border defined by the network command. For example:

interface FastEthernet0/0
 ip address 10.1.1.1 255.255.255.0

interface FastEthernet0/1
 ip address 10.2.2.1 255.255.255.0

interface FastEthernet1/0
 ip address 172.16.1.1 255.255.255.0

router rip
 version 2
 no auto-summary
 network 10.0.0.0

This RIPv2 will include both FE0/0 and FE0/1. If I just want FE0/0 to be included but not FE0/1, is it possible? Thanks in advance.

1

That depends on what you mean by included. You can use the passive-interface command to prevent that interface from sending RIP advertisements, or you can use a distribute list to filter advertised prefixes.


Chapter: IP Routing Protocol-Independent Commands: accept-lifetime Through passive-interface:

passive-interface

To disable sending routing updates on an interface, use the passive-interface command in router configuration mode. To reenable the sending of routing updates, use the no form of this command.

passive-interface [default] {interface-type interface-number}

no passive-interface interface-type interface-number


Chapter: RIP Commands:

distribute-list out (RIP, IGRP, EIGRP)

To suppress networks from being advertised in updates, use the distribute-list out command in address family or router configuration mode. To disable this function, use the no form of this command.

distribute-list {access-list-number | prefix prefix-list-name [gateway prefix-list-name]} out [interface-name | routing-process | as-number]

no distribute-list {access-list-number | prefix prefix-list-name [gateway prefix-list-name]} out [interface-name | routing-process | as-number]

| improve this answer | |
  • Thanks Ron. I tried passive-interface, but it didn't work. It seem like the passive-interface configuration only prevent the RIP update from sending out the configured interface, but the IP information of the passive interface can still be sent out through the other interface in RIP scope. In this example, if Fe1/0 is also added into RIP, and connected to another RIP enabled router B, even though Fe0/1 is set passive interface, router B still can learn the route to Fe0/1's IP. I think distribute-list out maybe a good choice. I will test it. – microbit Jun 22 '16 at 2:17
  • That is what passive interface does. Your question wasn't very clear by what you meant by excluded/included interface. If you want to exclude an interface from sending RIP updates, the passive-interface command is what you need. If you want RIP to exclude the advertisement of a prefix, then a distribute list is what you need. – Ron Maupin Jun 22 '16 at 2:20
  • Sorry about the ambiguity. EIGRP can use "network" command to specify which subnet can be advertised and which cannot. I just want to figure out whether RIPv2 has this function. It looks RIPv2 cannot do that. Thank you. – microbit Jun 22 '16 at 2:38
  • That's not entirely accurate. EIGRP and OSPF use the network command to determine which interfaces participate in the routing process, not to specify the prefixes advertised. The advertised prefixes will be taken from the network interfaces included in the address range. If your EIGRP network command doesn't include an interface, it is like the passive-interface command because it will not send network advertisements on that interface, and it will also not include the network on the interface. – Ron Maupin Jun 22 '16 at 2:41
  • I see. network command has two functions: 1. specify the interfaces that participate in protocol's route update communication. 2. Meanwhile, the interfaces' IP prefix will be added into advertisment. If you want a interface to receive route update, but not advertise its IP subnet, use distribute-list to filter the outgoing advertisements. Am I correct? – microbit Jun 22 '16 at 2:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.