2

My EX2200 is successfully giving out ip addresses over DHCP on interface ge-0/0/42. And only on that interface. Here is the config as I have it for that port, and the one next to it:

ge-0/0/42 {
     unit 0 {
          family inet {
               address 10.0.0.149/32
          }
     }

ge-0/0/44 {
     unit 0 {
          family inet {
               address 10.0.0.151/32
          }
     }

Now why is 42 working properly and 44 not? I did a show configuration, and I can't see any differences between the ports. Anyone got any ideas? I have plenty of addresses in the pool, and I've tested multiple devices on that port, so it gives them out fine.

set system services dhcp pool 10.0.0.0/24 address-range low 10.0.0.2
set system services dhcp pool 10.0.0.0/24 address-range high 10.0.0.252
set system services dhcp pool 10.0.0.0/24 router 10.0.0.1
4
  • 1
    Would you mind editing your question to include "show configuration | display inheritance | display set | match dhcp" The interface configuration by itself is not going to be enough to answer your question. The above request should be enough, or at the very least a starting point. Jun 24 '16 at 19:22
  • Done. Any other relevant info needed?
    – Dmitriy
    Jun 24 '16 at 19:25
  • It might just be easier to throw your entire configuration in here - just "show configuration" - feel free to obscure public IP's if you're concerned about that. Jun 24 '16 at 20:04
  • I'm surprised either worked since the interfaces are configured as /32s Oct 27 '16 at 10:52
0

Sorry about the long wait. I've solved the problem by now, and everything was wrong. I had to reload the factory config and start from scratch. In this case, it was just a matter of not setting up my interfaces properly and looking for answers on the wrong switch. And then messing with the config to death.

2
  • You should accept your answer so that the question doesn't keep popping up forever, looking for an answer.
    – Ron Maupin
    Dec 26 '16 at 14:27
  • Sorry about this!
    – Dmitriy
    Jan 3 '17 at 19:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.