2

I have a problem with stp(spanning tree protocal),most times we always set port to stp enable.but under the below switch every ports is set stp disable.I want to know the situation about when to set stp disable.thank you!

#               
interface GigabitEthernet1/0/1
 port link-mode bridge
 port access vlan 1000
 stp disable    
 arp detection trust
#               
interface GigabitEthernet1/0/2
 port link-mode bridge
 port access vlan 1000
 stp disable    
 arp detection trust
#               
interface GigabitEthernet1/0/3
 port link-mode bridge
 port access vlan 1000
 stp disable    
#               
interface GigabitEthernet1/0/4
 port link-mode bridge
 port access vlan 3
#               
interface GigabitEthernet1/0/5
 port link-mode bridge
 port access vlan 3
#               
interface GigabitEthernet1/0/6
 port link-mode bridge
 port access vlan 4
 stp disable    
#               
interface GigabitEthernet1/0/7
 port link-mode bridge
 port access vlan 1000
 stp disable    
#               
interface GigabitEthernet1/0/8
 port link-mode bridge
 port access vlan 1000
 stp disable    
  • that's definitely not a Cisco config, but I don'tknow what it is... could you tell us what the config is from? – Mike Pennington Jun 26 '16 at 13:51
  • 1
    Looks very Comware to me. My guess is that someone wanted to enable edge-port mode (like Cisco portfast) and confused that with disabling stp altogether, or thought that stp is not useful on edge ports. – Jeremy Gibbons Jun 26 '16 at 16:14
  • I was going to guess ExtremeOS – Tom O'Connor Jun 28 '16 at 16:57
2

This looks like comeware like in 3com or some HP branded (1900s and the enterprise 5000s)

The reason some people disable STP is to use it as an edge port. The reason for an edge port ...

When using standard STP with the fast computers of today a computer can boot and request DHCP before STP converges and allows the port to communicate. When this happens a computer doesn't get an ip address and it can't communicate.

Some other info:

Rapid spanning tree helps some of this issue by converging faster.

Cisco portfast will let the port come up first then check for loops.

Disabling STP per port turns it off completely off course.

I personally leave spanning tree on as often as possible. I've seen people plug loops in places you'd never guess!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.