2

We are provisioning a 4xT1 and a separate 3xT1 links to the same 2901 router with 4x VWIC3 - 2MFT T1 cards.

Verizon claims they cannot bond all 7 into a 7xT1 and have thus provisioned us these 2 links. I thought we would be able to load balance across the two links (via some agreed upon routing protocol) with some Verizon coordination; but now Verizon is saying they cannot as they go into separate routers on their end.

To make matters worse, they assumed, incorrectly, that these links would also go into 2 separate routers on our end as well and have given me the same DLCI's for both links.

My question is; if Verizon is unable/unwilling to work with us to load balance, is there some genius way of load balancing these 2 bonded frame relay links to give me a full 10 Mb of bandwidth without Verizon-side collaboration? (instead of the current and separate 6Mb and 4Mb links)

Thanks!

hostname 2901
!
enable secret cisco
!
card type t1 0 0
card type t1 0 1
card type t1 0 2
card type t1 0 3
!
no ipv6 cef
no ip source-route
ip cef
!
no ip domain lookup
ip name-server 198.6.1.142
ip name-server 198.6.100.53
!
!
controller T1 0/0/0
cablelength long 0db
channel-group 1 timeslots 1-24
!
controller T1 0/0/1
cablelength long 0db
channel-group 1 timeslots 1-24
!
controller T1 0/1/0
cablelength long 0db
channel-group 1 timeslots 1-24
!
controller T1 0/1/1
cablelength long 0db
channel-group 1 timeslots 1-24
!
interface MFR1
mtu 4470
no ip address
no ip redirects
no ip proxy-arp
encapsulation frame-relay IETF
load-interval 30
frame-relay multilink bid to gw
frame-relay lmi-type ansi
!
interface MFR1.500 point-to-point
ip address 1.130.197.162 255.255.255.252
no ip redirects
no arp frame-relay
no cdp enable
frame-relay interface-dlci 500 IETF
!
interface GigabitEthernet0/0
description CPE_LAN
ip address <LAN IP MASK>
no ip redirects
no ip proxy-arp
no ip mroute-cache
duplex auto
speed auto
no cdp enable
no shutdown
!
interface Serial0/1/0:1
description To CPE_WAN
no ip address
mtu 4470
bandwidth 1536
no ip mroute-cache
encapsulation frame-relay MFR1
!
interface Serial0/1/1:1
description To CPE_WAN
no ip address
mtu 4470
bandwidth 1536
no ip mroute-cache
encapsulation frame-relay MFR1
!
interface Serial0/1/2:1
description To CPE_WAN
no ip address
mtu 4470
bandwidth 1536
no ip mroute-cache
encapsulation frame-relay MFR1
!
interface Serial0/1/3:1
description To CPE_WAN
no ip address
mtu 4470
bandwidth 1536
no ip mroute-cache
encapsulation frame-relay MFR1
!
ip route 0.0.0.0 0.0.0.0 1.130.197.161

MLFR 3xT1

!
!
controller T1 0/2/0
cablelength long 0db
channel-group 2 timeslots 1-24
!
controller T1 0/2/1
cablelength long 0db
channel-group 2 timeslots 1-24
!
controller T1 0/3/0
cablelength long 0db
channel-group 2 timeslots 1-24
!
interface MFR1
mtu 4470
no ip address
no ip redirects
no ip proxy-arp
encapsulation frame-relay IETF
load-interval 30
frame-relay multilink bid to gw
frame-relay lmi-type ansi
!
interface MFR1.500 point-to-point
ip address 1.179.125.98 255.255.255.252
no ip redirects
no arp frame-relay
no cdp enable
frame-relay interface-dlci 500 IETF  
!
interface GigabitEthernet0/0
description CPE_LAN
ip address <LAN IP MASK>
no ip redirects
no ip proxy-arp
no ip mroute-cache
duplex auto
speed auto
no cdp enable
no shutdown
!
interface Serial0/1/0:1
description To CPE_WAN
no ip address
mtu 4470
bandwidth 1536
no ip mroute-cache
encapsulation frame-relay MFR1
!
interface Serial0/1/1:1
description To CPE_WAN
no ip address
mtu 4470
bandwidth 1536
no ip mroute-cache
encapsulation frame-relay MFR1
!
interface Serial0/1/2:1
description To CPE_WAN
no ip address
mtu 4470
bandwidth 1536
no ip mroute-cache
encapsulation frame-relay MFR1
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 1.179.125.97
6
  • Thank you Ron for fixing the formatting... still learning.
    – Helkas
    Jun 27, 2016 at 18:12
  • 2
    If the ISP isn't willing to setup their end, all you can control is what link your packet uses (outbound LB.) You will have no inbound balancing. Also, what "dlci conflict"? A DLCI only has meaning per link.
    – Ricky
    Jun 27, 2016 at 20:18
  • I apologize. I haven't touched frame relay in 10 years. I thought a DLCI of 500 on the same side on the same router would conflict. But it sounds like I have some frame relay fundamentals to brush up on. Thanks Ricky.
    – Helkas
    Jun 27, 2016 at 21:19
  • You also need to define what you mean by load balancing. You probably do not want to load balance per packet since this can lead to problems like out-of-order packet delivery.
    – Ron Maupin
    Jun 27, 2016 at 22:35
  • I think you need to get your carrier involved. Let them know you want the T1's bonded. MLPPP is often used for this purpose. Jun 28, 2016 at 1:21

1 Answer 1

3

Just an update. Verizon was able to collaborate on load balancing the 3xT1 and the 4xT1 using BGP. All is working as intended so far. Thanks all.

1
  • You should accept your answer so that the question doesn't keep popping up forever, looking for an answer.
    – Ron Maupin
    Aug 26, 2016 at 23:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.