1

Just wondering if you could help figure out what im trying to play with.
So Basically i have a Cisco 3750 Switch which is connected to my modem router. created 2 vlan(SALES and HR).
HOW CAN I GIVE ACCESS TO INTERNET FOR THIS PC's Connected to these vlans.

here are some config in my switch.
dsl modem router - 192.168.1.1
vlan1 (default) - 192.168.1.254 255.255.255.0
vlan 10 (SALES) - 192.168.10.1 255.255.255.0
vlan 20 (HR) - 192.168.20.1 255.255.255.0

int fa0/1 - connected to modem router
int range fa0/2-12 - switchport mode access and switchport access vlan 10
int range fa0/13-24 - switchport mode access and switchport access vlan 20

ip default-gateway 192.168.1.1
ip route 0.0.0.0 0.0.0.0 192.168.1.1

Am i missing something? hope you can help me out guys, thanks in advance and appreciate it so much.

2

I can see you have a default route to your modem/router, but it does not appear you have routing enabled.

Use

Switch(config)#ip routing

To enable routing. This in turn will allow inter vlan routing and allow data to get out from the other subnets to your DSL Modem/Router.

Make sure your client devices have the correct gateways set for the appropiate subnets.

If your DSL Modem/Router is not performing NAT already, you need to do what SystemCookie has posted and enable NAT on the Cisco switch.

Hope this helps on your quest.

SleepyMan

  • Cisco switches, except for the 6500, cannot NAT. Cisco claims you need special hardware to NAT, and it isn't available on switches. – Ron Maupin Jul 6 '16 at 17:21
0

I think you forgot to create NAT-Rules for the VLANS.

So you translate your internal IP to your Public IP.

This is on my Router configured:

nat (inside,outside) source static any interface unidirectional
  • Hi Sir; im still learning cisco devices, and i have not touched NAT topics yet, was just excited to try vlans and play with it. based from my reading just awhile ago, NAT is not support in 3750. – ytse_jam Jul 6 '16 at 11:32
  • I think their is no need anymore for explaination. Greets :-) – SystemCookie Jul 6 '16 at 12:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.