1

I apologize if this is an easy fix, but I just got a used 2960 series S switch and am unable to connect to it through the default gateway. I am using a straight-through, RJ-45 connector ethernet cable with DHCP enabled. I power on the switch and wait till the POST finishes before connecting the ethernet cable, and then wait until the light above the port starts blinking green, afterwards I hold down the mode button until all the lights turn a solid green (to enter into express setup.) When I try to go to the default gateway (10.0.0.1 according to the online documentation) my browser (chrome) says that the site can't be reached. When I type ipconfig into the command line, the line which lists the default gateway is empty. Some of the things I have tried are:

  • Connecting from both Windows 10 and Fedora 23 (with DHCP enabled on both.)
    • Connecting from both my laptop and my desktop.
    • Using a different ethernet cable (still RJ-45 straight-through.)
    • Using different ports on the switch (I started with port 1 but have tried several others.)
    • Factory reset the switch by holding down the mode button until the device cycles through POST again.
    • Attempted to SSH into the switch using PUTTY on address 10.0.0.1

I hope I have given enough information, I am new to networking so if there is anything else I can provide just let me know.

Edit: I am using a Lenovo Z400 touch laptop to connect to the switch with a RealTek PCIe Family Controller for the ethernet.

  • 1
    You should edit your question to include more details. At the very least, your should include the switch configuration. What device and model is the gateway to which you have connected the switch? – Ron Maupin Jul 13 '16 at 3:28
  • The easiest way to troubleshoot this it to connect trough the serial console. You should have a mini usb connector on the switch. Can you connect it? (if needed download the driver from Cisco download site). – JFL Jul 13 '16 at 7:44
  • @RonMaupin I'm afraid I don't know the switch configuration as I'm unable to connect with it in anyway. As for the device model and gateway connecting to the switch, I am using a Lenovo Z400 touch with a RealTek PCIe Family Controller for the ethernet (I'll add these details to my original post.) I attempted to connect to the switch via the default gateway provided by the Cisco documentation (IP 10.0.0.1). I hope I understood the information you desired, as I mentioned, I'm new to networking, so I'm a little unfamiliar with the technical details. – turtleone2000 Jul 14 '16 at 0:28
  • @JFL I have the serial connector and I bought a DB9 to USB converter today so I can access it through my laptop. I installed the driver for the converter from the CD included with it and set it up according to the documentation (9600 baud, 8 data bits, no parity, 1 stop bit, and no flow control.) I attempted to connect to the switch via PUTTY serial console on COM3 (the port listed in the device manager for the converter) but I only get a blank, black terminal with a solid green rectangle for the cursor, but I cannot input anything. Any recommendations for continuing? – turtleone2000 Jul 14 '16 at 0:36
  • If you can't get to the configuration, how do you know the configured IP address for the switch? I meant the gateway (router) to which the switch is connected, not your PC; you wrote that you were trying to get to it through the gateway. If you can't connect via the network, you will need to connect to the console, and you may need to perform a password recovery to get in. – Ron Maupin Jul 14 '16 at 2:55
1

You will need to log on to the switch via console cable (light blue with a serial port on one end and an rj45 on the other end- you can buy USB adaptors for it if you don't have a serial port on your PC/Laptop). In my experience you when you first start a fresh install/config of a device you will have to set SSH access through the line vty transport input telnet/ssh command. You will also need to create and open a VLAN, assign that an IP address then 'noshut' an interface, chuck it in a VLAN. You can connect a cable to that that port and then connect via putty using ssh to the switch using the IP address you assigned the VLAN. Hope this helps.

  • As I mentioned above, I got a db9 to usb converter today so I could use the console port. I installed the driver for the adapter and set it up according to the cisco documentation (the settings are in my comment above addressed to JFL.) When I attempted to connect via serial connection to the switch I only received a blank, black terminal with a solid green rectangle for the cursor, but it appears as though I cannot input anything. The connection seems to have been established, but I'm new to operating in a network terminal so any advice to continue would be appreciated. – turtleone2000 Jul 14 '16 at 0:40
  • I finally got in, I didn't know you were supposed to hit 'enter' twice when the terminal came up. After finding that tidbit on a cisco forum (supportforums.cisco.com/discussion/11084186/…) I'm finally in and got it configured. Thanks a bunch everyone! – turtleone2000 Jul 15 '16 at 1:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.