1

I'm trying to set up this configuration for testing purposes, but it's not working at all and I don't know why:

enter image description here

The problem is that R3 is not receiving any learned route from bgp neigbors

The config:

Router R1

interface FastEthernet0/0
 ip address 192.168.35.209 255.255.255.240
 speed 100
 full-duplex
!
interface FastEthernet0/1
 ip address 192.168.34.10 255.255.255.128
 duplex auto
 speed auto
!
router bgp 35
 no synchronization
 bgp log-neighbor-changes
 redistribute connected
 neighbor 192.168.34.3 remote-as 33
 neighbor 192.168.35.210 remote-as 35
 no auto-summary
!

Router R2

 interface GigabitEthernet0/0
     ip address 192.168.35.225 255.255.255.240
     duplex full
     speed 100
    !
    interface GigabitEthernet0/1
     ip address 192.168.35.210 255.255.255.240
     duplex full
     speed 100
    !
    router bgp 35
     bgp log-neighbor-changes
     redistribute connected
     neighbor 192.168.35.209 remote-as 35
     neighbor 192.168.35.226 remote-as 35
     no auto-summary
    !

Router R3

interface FastEthernet0/0
 ip address 192.168.35.241 255.255.255.240
 speed 100
 full-duplex
!
interface FastEthernet0/1
 ip address 192.168.35.226 255.255.255.240
 speed 100
 full-duplex
!
router ospf 1
 no compatible rfc1583
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0
!
router bgp 35
 no synchronization
 bgp log-neighbor-changes
 redistribute connected
 neighbor 192.168.35.225 remote-as 35
 no auto-summary
!

As I said before, R3 is not receiving routes from BGP neigbors, for example, the route to 192.168.34.0/25 from F0/1 of R1.

ROUTER3#sh ip bgp
BGP table version is 14, local router ID is 192.168.35.241
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i192.168.35.208/28
                    192.168.35.225           0    100      0 ?
*> 192.168.35.224/28
                    0.0.0.0                  0         32768 ?
* i                 192.168.35.225           0    100      0 ?
*> 192.168.35.240/28
                    0.0.0.0                  0         32768 ?
ROUTER_OP1.3#

However, R2 and R1 are receiving all routes:

ROUTER1#sh ip bgp
BGP table version is 292, local router ID is 1.1.35.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 10.194.0.0/20    192.168.34.3                           0 33 i
*> 10.197.48.0/20   192.168.34.3                           0 33 i
*> 172.31.48.0/24   192.168.34.3                           0 33 i
*> 172.31.49.0/24   192.168.34.3                           0 33 i
*> 192.168.34.0/25  0.0.0.0                  0         32768 ?
* i192.168.35.208/28
                    192.168.35.210           0    100      0 ?
*>                  0.0.0.0                  0         32768 ?
*>i192.168.35.224/28
                    192.168.35.210           0    100      0 ?
ROUTER1#

ROUTER2#sh ip bgp
BGP table version is 343, local router ID is 1.1.35.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, x best-externa
l
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i10.194.0.0/20    192.168.34.3             0    100      0 33 i
*>i10.197.48.0/20   192.168.34.3             0    100      0 33 i
*>i172.31.48.0/24   192.168.34.3             0    100      0 33 i
*>i172.31.49.0/24   192.168.34.3             0    100      0 33 i
*>i192.168.34.0/25  192.168.35.209           0    100      0 ?
*> 192.168.35.208/28
                    0.0.0.0                  0         32768 ?
* i                 192.168.35.209           0    100      0 ?
* i192.168.35.224/28
                    192.168.35.226           0    100      0 ?
*>                  0.0.0.0                  0         32768 ?
*>i192.168.35.240/28
                    192.168.35.226           0    100      0 ?

If you need additional info, please ask for more

  • Did any answer help you? if so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer. – Ron Maupin Aug 12 '17 at 18:51
1

The rule for iBGP is that an iBGP peer cannot advertise iBGP routes learned from another iBGP peer. That means that each iBGP peer must be in a full mesh with every other iBGP peer, or you must use a mitigation, e.g. route reflectors or confederations. This is a loop prevention mechanism.

R3 can only learn eBGP routes from R1 because R2 cannot pass on iBGP routes originated by R1 to R3. R3 would also need to directly peer with R1, and that usually involves an IGP. Alternatively, you could configure R2 as a route reflector.

| improve this answer | |
  • and what about if I configure this in R1: "neighbor 192.168.35.226 remote-as 35" and in R3 "neighbor 192.168.35.209 remote-as 35" – xavidpr4 Aug 19 '16 at 10:05
  • If you have a full mesh, each iBGP router has a connection to every other iBGP router, and you configure each as a neighbor of the others, then you are fine. You will either need to use an IGP, or you will need to have a physical connection between each of the iBGP peers. – Ron Maupin Aug 19 '16 at 10:08
  • Another problem is NEXTHOP. iBGP keep it intact by default, so R3 get routes with gateway 192.168.35.209 and it unreachable. – mmv-ru Aug 19 '16 at 22:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.