1

I've built a scenario in Packet Tracer that I am looking at implementing but having issues with pinging from a PC through a L3 switch. From the switch, I can ping every IP address in the environment but any device connected to inside of the switch cannot ping outside the switch. I have done this before and am perplexed by this. Not sure if it's Packet Tracer or me.

Layout

Here is the switch config:

HM_SW1#sh run
Building configuration...
Current configuration : 1823 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname HM_SW1
!
ip dhcp excluded-address 192.168.1.1
ip dhcp excluded-address 192.168.1.50
!
ip dhcp pool 192
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 10.10.0.40
!
ip routing
!
spanning-tree mode pvst
!
interface FastEthernet0/1
switchport access vlan 192
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
switchport access vlan 100
!
interface FastEthernet0/11
switchport access vlan 10
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
switchport access vlan 192
!
interface GigabitEthernet0/1
no switchport
ip address 10.255.255.2 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
!
interface Vlan10
mac-address 0005.5ec9.1601
ip address 10.10.0.1 255.255.255.0
!
interface Vlan100
mac-address 0005.5ec9.1602
ip address 10.100.0.1 255.255.255.0
!
interface Vlan192
mac-address 0005.5ec9.1603
ip address 192.168.1.1 255.255.255.0
!
ip default-gateway 10.255.255.1
ip classless
ip route 0.0.0.0 0.0.0.0 10.255.255.1
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end

Thanks

3
  • What are the router configurations? How do they know about the networks behind the layer-3 switch? Ping is a two-way application, and the routers must be able to return traffic to the networks behind the switch, and if they don't know where the networks are, the traffic will be dropped. You either need to configure static routes on all the routers for those networks, or you need to run a routing protocol to share the route to those networks. – Ron Maupin Aug 19 '16 at 22:33
  • Do hm_r1 and the other outside devices have routes to the inside networks? – hertitu Aug 19 '16 at 22:34
  • DOH! I had a feeling it was something simple. Added the routes to HM_R1 and voila. Thanks guys! – Brian S Aug 19 '16 at 22:43
1

What are the router configurations? How do they know about the networks behind the layer-3 switch? Ping is a two-way application, and the routers must be able to return traffic to the networks behind the switch, and if they don't know where the networks are, the traffic will be dropped. You either need to configure static routes on all the routers for those networks, or you need to run a routing protocol to share the route to those networks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.