1

I have two routers (layer 3 switches to be honest: ex4200 and ex2200). I have zeroized both of them before starting this config. I have set up ge-0/0/12 on one as unit 0 family inet address 10.0.0.1/24 and 10.0.0.2/24 on the other and connected them. I set up ospf on both devices as follows: set protocols ospf area 0.0.0.0 interface ge-0/0/12. run show ospf neighbor tells me that I have a Full state, so the routers have paired. Next, I want to export some routes from one device to the other, but none of the routes I have on either device are being exported. Have I skipped some step?

  • What did you do to advertise the routes? Did you put the interfaces of the routes into OSPF? You should show your configurations. – Ron Maupin Aug 19 '16 at 23:59
2

OSPF Feature Guide for EX4600 Switches > Juniper OSPF Overview

CLI Quick Configuration

To quickly configure an OSPF interface on a broadcast or point-to-point network and to allow the inbound OSPF into the interfaces that are active, copy the following commands, paste them into a text file, remove any line breaks, change any details necessary to match your network configuration, copy and paste the commands into the CLI at the [edit] hierarchy level, and then enter commit from configuration mode.

set interfaces ge-0/2/0 unit 0 family inet address 10.0.0.1
set protocols ospf area 0.0.0.1 interface ge-0/2/0
set security zones security-zone Trust host-inbound-traffic protocols all
set security zones security-zone Trust host-inbound-traffic system-services all
set groups global security policies default-policy permit-all
set security zones security-zone Trust interfaces ge-0/2/0
| improve this answer | |
  • That looks like config for a SRX, not an EX series switch. – Mark Aug 22 '16 at 13:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.