1

I enabled SNMP and Traps on a cisco router and I used snmp-server enable traps cpu threshold command in configuration mode.

I configured LinkUp-Down Traps with snmp-server enable traps snmp linkup linkdown and this is send traps to 172.16.98.28/24 host and after enable cpu threshold, no traps send to 172.16.98.28/24 host.
What's wrong?

My Device: c3640 IOS 12.4

8
  • 1
    You really need to give more detail. You should edit your question to include the device model and configuration. Are you running SNMP software on the host at 172.16.98.28? – Ron Maupin Aug 22 '16 at 11:12
  • Can you clarify the question as well please? Are you saying that LinkUp/Down traps were working fine but you no longer see LinkUp/Down traps (when there is a linkUp/down event) after enabling traps for CPU threshold? Or that you are not seeing CPU threshold traps (when CPU is high)? Or both? – hertitu Aug 22 '16 at 15:06
  • @RonMaupin I'm sorry, my device is c3640. Yes, I used iReasoning MIB Browser on the host at 172.16.98.28 and c3640 has response to my snmp request. How to enable CPU Utilization Traps? – M. Rostami Aug 22 '16 at 18:36
  • You seem to be mixing up snmptraps and snmp queries. You can't use a MIB browser to request traps, you'll need a trap receiver to collect them. – Teun Vink Aug 22 '16 at 18:45
  • @hertitu LinkUp/Down traps has Worked but after typing this command snmp-server enable traps cpu threshold, I have not received trap about CPU. – M. Rostami Aug 22 '16 at 18:47
1
  • Step 1 : snmp-server enable traps cpu threshold
  • Step 2 : process cpu threshold type total rising 80 interval 5

In Step 1 i'm enabled CPU Threshold Trap and in Step 2 i'm enabled CPU Threshold for each 5 second if CPU percent is 80.

1
  • You should accept your answer so that the question doesn't keep popping up forever, looking for an answer. – Ron Maupin Aug 23 '16 at 11:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.